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Environmental Considerations

Environmental Considerations
This section provides information about the environmental impact of the product.

Product End-of-Life Handling
Observe the following guidelines when recycling an instrument or component:

Equipment Recycling. Production of this equipment required the extraction and use of natural resources.
The equipment may contain substances that could be harmful to the environment or human health if
improperly handled at the product’s end of life. In order to avoid release of such substances into the
environment and to reduce the use of natural resources, we encourage you to recycle this product in an
appropriate system that will ensure that most of the materials are reused or recycled appropriately.

This symbol indicates that this product complies with the European Union’s requirements according to
Directive 2002/96/EC on waste electrical and electronic equipment (WEEE). For information about recycling
options, check the Support/Service section of the Tektronix Web site (www.tektronix.com).

xxx

Restriction of Hazardous Substances
This product has been classified as Monitoring and Control equipment, and is outside the scope of the
2002/95/EC RoHS Directive.
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Introduction to the Application Using Online Help

Using Online Help
The XGbT online help serves as a reference for using the 10GBASE-T Ethernet Compliance Test Software.

Contents. The Contents tab displays books and pages that represent the categories of information in
the online Help system. The Search tab enables you to search for keywords in the Help system and to
locate topics containing those words.

Back and Forward. The Back and Forward buttons allow you to browse through topics.

Index. The Index tab displays a multi-level list of keywords and keyword phrases. These terms are
associated with topics in the Help system and direct you to specific topics.

Search. When the search is completed, a list of topics is displayed so that you can select a specific
topic to view.

To print a topic. Select the Print button from the Help Topics menu bar.

While using the online help, you can print topics and information from the HTML Help viewer.

To print a single topic.

1. Find the topic in the Contents tab.

2. Click Print.

3. Click Print the selected topic and click OK.

To print all topics in a selected TOC book.

1. Find the TOC book in the Contents tab.

2. Click Print.

3. Click Print the selected heading and all subtopics and click OK.

TIP. If topics include expanding or drop-down hot spot, click the hotspots to display the information
before you print.
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Introduction to the Application Related Documentation

Hotspot is a clickable text that displays additional information below the link. Click on the hotspot
text to show or hide the hotspot content.

Related Documentation
The following manuals are available as part of the TekExpress XGbT-10GBASE-T Automated Solution
documentation set.

Table 1: Product documentation
Item Purpose Location
PDF of the Online Help
(077-0348-XX)

In-depth operation and UI help.

Reference (077-0349-XX) High-level installation information

Test Fixture Reference
(077-0390-XX)

High-level test fixture

xxx

Other documents

http://www.tek.com/Measurement/applications/serial_data/ethernet.html.

For information on USB-MPC device, refer to http://www.teamfdi.com/pages/products_index.html.

4 TekExpress XGbT-10GBASE-T Automated Solution

http://www.tek.com/Measurement/applications/serial_data/ethernet.html
http://www.teamfdi.com/pages/products_index.html


Introduction to the Application Conventions

Conventions
Online Help uses the following conventions:

The term “XGbT” refers to Extended 10GBASE-T Attachment.

The term “DUT” is an abbreviation for Device Under Test.

The term “select” is a generic term that applies to the two mechanical methods of choosing an option:
using a mouse or using the touch screen.

Table 2: Icon descriptions
Icon Meaning

This icon identifies important information.

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the application more
efficiently.

xxx
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Introduction to the Application Technical Support

Technical Support
Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on your application or oscilloscope.

When you contact Tektronix Technical Support, please include the following information (be as specific as
possible):

General Information
All instrument model numbers.

Hardware options, if any.

Probes used.

Your name, company, mailing address, phone number, FAX number.

Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application Specific Information
Software version number.

Description of the problem such that technical support can duplicate the problem.

If possible, save the setup files for all the instruments used and the application.

If possible, save the TekExpress setup files, log.xml and status messages text file.

If possible, save the waveform on which you are performing the measurement as a .wfm file.

Forward the information to technical support using one of these methods:

E-mail – techsupport@tektronix.com

FAX – (503) 627-5695

6 TekExpress XGbT-10GBASE-T Automated Solution



Getting Started Accessories

Accessories

About the Test Fixture
The TF-XGbT test fixture is ROHS compliant and provides the functionality as described in IEEE
802.3an-2006 sub-clause 55.5.2.1. The test fixture is needed to perform the conformance tests and device
characterization for 10GBASE-T Ethernet electrical signals.

Products supported
Tektronix DPO7354 Digital Oscilloscope

Tektronix DPO/DSA70404, DPO/DSA70604, DPO/DSA70804, DPO/DSA71254, DPO/DSA71604,
and DPO/DSA72004 Series Digital Oscilloscopes

Tektronix DPO/DSA70404B, DPO/DSA70604B, DPO/DSA70804B, DPO/DSA71254B,
DPO/DSA71604B, and DPO/DSA72004B Series Digital Oscilloscopes

Tektronix MSO70404, MSO70604, MSO70804, MSO71254, MSO71604, and MSO72004 Series Mixed
Signal Oscilloscopes

Recommended AWGs for Return Loss Measurement. Tektronix AWG7101, AWG7101B, AWG7102,
and AWG7102B

Table 3: Recommended probes

Oscilloscope model

For Droop, Power Spectral Density, Linearity,
Clock Frequency, Jitter-Master, and Jitter-Slave
measurements

For Return Loss
measurement

Tektronix P6330 - A minimum of one and a
maximum of four are required.

Tektronix P6330 - A minimum
of two are required.

SMA cables - A minimum of two are required.

DPO7354

Tektronix TDP3500 - A minimum of one and a
maximum of four are required.

Tektronix TDP3500 - A
minimum of two are required.

P6330 - A minimum of one and a maximum of
four are required.

P6330 - A minimum of two
are required.

P7330 and P7350 - A minimum of one and a
maximum of four are required.

P7330 and P7350 - A
minimum of two are required.

Trimode probes (P7520, P7516, P7513A, P7508,
P7506, and P7504) - A minimum of one and a
maximum of four are required.

Trimode probes (P7520,
P7516, P7513A, P7508,
P7506, P7504) - A minimum
of two are required.

SMA cables - A minimum of two are required.

DPO70000, DSA70000,
MSO70000, DPO70000B, and
DSA70000B Series

P7350SMA, P7380SMA, and P7313SMA - A
minimum of one and a maximum of four are
required.

P7340A, P7360A, P7313,
and P7380A - A minimum of
two are required.
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Table 3: Recommended probes (cont.)
xxx

Minimum System Requirements
The minimum system requirements for a PC to run TekExpress are as follows:

Table 4: System requirements
Processor Pentium 4/M or equivalent processor.
Operating System Windows XP Service Pack 2.
Memory 512 MB of memory.
Hard Disk Approximately 2 GB of available hard-disk space for the recommended

installation, which includes full TekExpress installation and distributed
components.

Drive DVD drive.
Display Super VGA resolution or higher video adapter (800x600 minimum video

resolution for small fonts or 1024x768 minimum video resolution for large fonts).
The application is best viewed at 96 dpi display settings 1.

Software Microsoft Excel 2002 or above.

Microsoft Internet Explorer 6.0 SP1 or later.

Microsoft Photo Editor 3.0 or equivalent software for viewing image files.

Adobe Reader 6.0 or equivalent software for viewing portable document
format (PDF) files.

Other Devices Microsoft compatible mouse or compatible pointing device.

Four USB ports (two USB ports minimum).

PCI-GPIB or equivalent interface for instrument connectivity 2.
xxx

1 If TekExpress is running on an instrument having a video resolution lower than 800x600 (for example, sampling oscilloscope), it is recommended
to connect a secondary monitor and this must be enabled before launching the application.

2 If TekExpress is installed on a Tektronix oscilloscope, the virtual GPIB port will be used by TekExpress for communicating with oscilloscope
applications. If external GPIB communication devices like USB-GPIB-HS or equivalent are used for instrument connectivity, ensure that the Talker
Listener utility is enabled in the DPO/DSA oscilloscope’s GPIB menu.

Install the Software
1. Close all applications.

2. Download XGbTWebinstaller_<version>.EXE.

3. Double-click the executable to extract the files. After extraction, the XGbT installer launches
and the software is installed in C:\Program Files\Tektronix\TekExpress\TekExpress

XGbT-10GBASE-T.
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Application Directories and Usage
The application directory and associated files are organized as follows:

The following table lists the default directory names and their usage:

Table 5: Application directories and usage
Directory names Usage
InstallDir\TekExpress Contains the application and associated files.
\TekExpress\Compliance Suites Contains compliance specific files.
\TekExpress\Bin
\TekExpress\Lib
\TekExpress\Tools

Includes the Miscellaneous libraries of the XGbT application.
Includes utility files specific to the XGbT application.
Includes instrument application specific files for XGbT application.

\TekExpress\ACP
\TekExpress\SCP
\TekExpress\ICP

Includes instrument and application specific interface libraries of
the XGbT application.

\TekExpress\Documents Includes the Method of Implementation documents and technical
documentation for the application.

\TekExpress\Data Manager
\TekExpress\Data Storage
\TekExpress\Report Generator

Includes the result management specific libraries of the XGbT
application are present in these folders.
Includes Excel Active X interface Library for Report Generation.

xxx
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File Name Extensions
The software uses the following file name extensions:

Table 6: File name extensions
File name extension Description
.TekX The session file will be saved in this format.
.seq The test sequence file.
.xml The encrypted XML file that contains the test specific configuration

information.
The log file extension is also xml.

.wfm The test waveform file.

.mht The measurement result report will be saved in this format.
xxx

Activate the License
Follow the steps below to activate the license:

1. Click Help > Activate License or Help > About TekExpress > License Info to view the license
information and activate the application.

2. Click the View Version Details link to check the version numbers of the installed test suites.
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3. Click the View End-User License Agreement link to open the following Tektronix Software License
Agreement window. Click Print to print the License Agreement.

4. Click the License Info to view the available software options. This window shows the license key and
the various options with their status (active or inactive) with the current license key.

a

5. If you are activating the license for the first time, the license key field will be empty. To activate the
license, connect the USB dongle to your computer, enter the license key provided in the license key
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certificate, and click Activate. If the activation is successful, a sign is displayed next to the license
key field.

6. If you are reactivating the license, click Reactivate, enter the new license key and click Activate.

Before You Click Run
After you install XGbT, it creates the following folders on your computer:

\Program Files\Tektronix\TekExpress\TekExpress XGbT-10GBASE-T.

NOTE. Ensure that the “TekExpress” folder has read and write access.

\My Documents\My TekExpress\XGbT-10GBASE-T.

\My Documents\My TekExpress\XGbT-10GBASE-T\Untitled Session.

Every time the TekExpress XGbT-10GBASE-T.exe is launched, an Untitled Session folder is
created under XGbT-10GBASE-T folder. The Untitled Session folder is deleted when you exit the
XGbT application.

CAUTION. Each session has multiple files associated with it. Do not modify any of the session files and/or
folders as this may result in loss of data or corrupted session files.

The My TekExpress folder is created as a shared folder with share name as <domain><user ID>My
TekExpress (or if the PC is not connected to domain, then share name is <Computer name><user

ID> My TekExpress).

The above shared folder is mapped as X: (X drive) on to the instrument where 10GBASE-T is running.

NOTE. If X drive is mapped to any other shared folder, 10GBASE-T will display a warning message
window asking you to disconnect the X: drive manually.

Do the following before you click Run:

NOTE. Ensure that the network connectivity is enabled on the instrument running the 10GBASE-T
application.
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1. Map the shared My TekExpress folder as X: (X drive) on all the instruments used in test setup running
Microsoft Windows Operating System. This shared folder is used to save the waveform files or
used during any other file transfer operations.

2. Right-click on the My TekExpress folder and open the Properties dialog box. Select the General tab
and then Advanced. In the Advanced Attributes window, ensure that the option Encrypt contents
to secure data is NOT selected. Click here to view the picture.

3. Ensure that all the required instruments are properly warmed up, Signal Path Compensation (SPC)
performed, followed by cable deskew.

Mapping My TekExpress Folder
To map the My TekExpress folder on the instruments, follow the steps below:

1. Open Windows Explorer.

2. From the Windows Explorer menu, select Tools > Map Network drive.

3. Select the Drive letter as X: (if there is any previous connection on X:, disconnect it first through
Tools > Disconnect Network drive menu of Windows Explorer).

4. In the Folder field, enter the remote My TekExpress folder path (for example, \\192.158.97.65\
John’s My TekExpress)

5. You can determine the IP address of the PC where “My TekExpress” folder exists by doing
the following:

Select Start > Run menu on the PC where the My TekExpress folder exists.

Enter cmd and press Enter.

At the command prompt, type ipconfig.
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You can find SPC by following the steps:

1. On the oscilloscope main menu, select the Utilities menu.

2. Click the Instrument Calibration option.
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XGbT Application Overview
TekExpress is the Tektronix Compliance Test Automation Framework, developed to support current and
future test automation needs of customers. Developed using National Instruments’ TestStand, TekExpress
leverages on the capabilities of Microsoft .NET framework. It uses a highly modular architecture that
enables deploying automated test solutions for various standards in a relatively short time.

Key Features
The key features of the application are as follows:

Provides an automated solution for performing Clock Frequency, Droop, Jitter-Master, and Jitter-Slave
measurements in compliance with IEEE 802.3an-2006, sub clause 55.5.3. Using the spectral features
of the oscilloscope, the application also facilitates performing spectral-based measurements such as
Power Spectral Density, Power Level, Linearity (All Tones), and Return Loss.

XGbT users will also have to qualify their DUTs for 1000BASE-T/100BASE-T/10BASE-T
compliance. To meet this, Tektronix provides the necessary softwares (TekExpress XGbT-10GBASE-T
Automated Solution and TDSET3 Ethernet Compliance Software), fixtures (TF-XGbT and TF-GBE),
oscilloscopes, Arbitrary Waveform Generators, and probes. This takes away the burden of designing
their own fixture.

Facilitates selecting, configuring, and running measurements. You can also perform the measurements
on all four lanes in one click and reduce the testing time.

Generates well correlated, repeatable, and accurate results using SMA cables and probes. The results
obtained for spectral-based measurements Power Spectral Density and Linearity using an oscilloscope
correlate well with the results obtained using a spectrum analyzer.

For a selected measurement test suite, the MDIO Automation Controller helps in setting up the test
mode automatically. You can avoid setting the test mode manually and also have the flexibility of
working at your desk.

Ensures that you calibrate the selected lane at least once before running the Return Loss measurement.
This way you can run the Return Loss measurement multiple times on the calibrated lane.

Performs marginal testing that is flexible and beyond what is specified in the IEEE standard for Droop,
Power Spectral Density, and Linearity measurements.

Provides a summary report of all lanes and detailed reports of each lane in the report panel. Test
margins and statistical information help you to find answers quickly. You can save the reports
in MHT format.

Provides you the flexibility to work in comfort at your desk, as it allows you to load and run the
application on your desktop and laptop computer. Use an Ethernet or USB-GPIB cable to connect to
an oscilloscope.

Helps in debugging and designing the 10GBASE-T PHY layer and analyzing it beyond compliance
needs.

Seamlessly integrates with high-level TestStand Automation Layer.
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Powered by NI TestStand™.

Previous versions of TekExpress use NI LabVIEW™ for instrument control.

You can automate your test bench by saving and recalling setup files in your automation script. You can
call TekExpress XGbT-10GBASE-T application programmatically through NI LabVIEW/NI TestStand
for controlling XGbT along with the other test components like Thermal chambers and Power supplies.
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It also reduces the implementation time for the automation design and to integrate TekExpress with the
existing NI LabVIEW automation for various qualification and environmental tests.

Starting the Application
The application uses a USB dongle that contains the license key. This dongle must be present on the
instrument hosting the XGbT application.

The application also checks for a file, called Resources.xml, located in My TekExpress folder. If this file
is not found, instrument discovery is performed before launching 10GBASE-T. The Resources.xml file
contains information regarding instruments available on network.

When the application starts, it checks for the appropriate license key. If the valid license key is not present,
the application switches to the “Demo” mode. If the application fails to detect the dongle, it continues
to run in Demo mode.

To start the application, you can do one of the following:

Click Start > Programs > Tektronix > TekExpress > TekExpress XGbT-10GBASE-T.

Double click the icon on the desktop.

If you have previously saved a session, you can double-click the session file stored under My
TekExpress\10GBASE-T.

NOTE. If the application was not terminated properly during the last use, a dialog box asks to recall the
previously unsaved session.
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Resizing the Application Window

To minimize the application, click on the application title bar. To restore the application to its previous

size, select in the Windows task bar.

To maximize the application, click . To restore the application to its previous size, click on the
application title bar.

Exiting the Application
To exit the application, do one of the following:

Click File > Exit.

Click on the application title bar.

NOTE. Using other methods to exit the application results in abnormal termination of the application.
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Global Controls
The menus and controls that appear outside the individual tabs are called “Global Controls”. These are
used to specify the devices to be tested.

Table 7: Global controls
Control name Function
DUT The device ID is specified at the global level and the

information is stored in the default location for all data
files. This field cannot be empty and does not allow these
special characters (.,..,...,\,/:?”<>|*). The maximum length
of characters allowed is 32.
Displays the status of the disk space. When the disk space
is low, a warning dialog appears to perform the cleanup and
continue working on the application.
You will be able to run, pause, resume, and stop the tests.

xxx
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Menus

File Menu
Click File on the application menu bar.

The File menu has the following selections:

Table 8: File menu
Menu Function
New Session Starts a default session of 10GBASE-T.
Open Session Opens a saved session.
Save Session Saves the session.
Save Session As Saves a session in a different name.
Recently Recalled Setup Recalls the recently saved setup.
Save Report As Saves the report in user specified location.
Print Preview Report Previews the report before printing.
Print Report Opens the Windows “Print” dialog box.
Exit Closes the application.
xxx
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View Menu
Click View on the application menu bar.

The View menu has the following selections:

Table 9: View menu
Menu Function
Log Opens the log (log.xml) file in the default viewer.
xxx

Tools Menu
Click Tools on the application menu bar.

The Tools menu has the following selections:

Table 10: Tools menu
Menu Function
Instrument Bench Shows the list of instruments connected to the test setup.
E-mail Setting Allows you to configure and set the e-mail options.
Return Loss Calibration Ensures that the calibration for Return Loss measurement

is performed before running the test.
xxx

Instrument Bench
The Instrument Bench window shows the list of VISA and Non-VISA resources found on different
interfaces/connections. It serves two purposes at the launch of TekExpress:

Discovers the connected instruments.

Confirms the instrument connection setup.
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When you click Tools > Instrument Bench, the following dialog box is displayed:

E-mail Settings
The E-mail Settings utility allows you to configure and set the e-mail options. The following fields are
mandatory for receiving e-mail notification from TekExpress:

1. Recipient Email Addresses. For example, User@domain.com

2. Sender’s Address

3. SMTP Server address of the Mail server configured at client location

If any of the above mentioned fields are left blank, the settings will not get saved and e-mail notification
will not be sent.
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Check the option “E-mail Test Results When Complete or on Error” to receive the e-mail. The attachment
list depends on the choice which is made while configuring the email setup.

NOTE. The Analysis Screenshot option in the Add Email Attachments pane is not yet functional.

Return Loss Calibration
Click Tools > Return Loss Calibration to display the Return Loss Calibration dialog box.
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Use the Return Loss Calibration to do the following:

Perform live calibration for the Return Loss measurement.

Perform calibration using the files of the earlier calibration for the Return Loss measurement.

Help Menu
Click Help on the application menu bar.

The Help menu has the following selections:

Table 11: Help menu
Menu Function
TekExpress Help Displays TekExpress Help (F1).
About TekExpress Displays the TekExpress Mock up screen with description

of 10GBASE-T heading “TekExpress XGbT-10GBASE-T
Automated Solution”. Also displays the application details
such as software name, version number, and copyright.

Activate License Displays the details of activating the application.
xxx
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Select Test(s)
The application tests the following measurements:

Droop

Power Spectral Density

Linearity

Clock Frequency

Jitter-Master

Jitter-Slave

Return Loss

The Select panel allows you to select, configure, and run the tests.

The application allows you to select a subset of tests to execute.

Source. Select the Source type. Differential is the default. The Test Lanes option is automatically updated
corresponding to the selected source.
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Test Lanes. Select the Test Lanes. Select Lane option is the default. You can select one of the available
lanes.

Table 12: Button controls on the Select panel
Button Description

Opens the configuration panel for the selected test.

Opens the schematic for the selected test. This is useful if
you want to verify the test setup before running the test.
Selects all tests in the table.

Deselects all tests in the table.

Performs calibration on the selected lane for the Return Loss
measurement.
Appears when the selected lane has already been calibrated
for the Return Loss measurement. Click Re-Calibrate button
to calibrate on the selected lane again.

xxx

Configure and Run the Test(s)
The configuration panel is used to view and edit the parameters associated with the acquisition and the
analysis of the selected test. Click here for the options.
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NOTE. If any of the test parameters are grayed, it means that these parameters are not editable.

Table 13: Button controls on the Configure panel
Configure parameters Description
Acquire Shows the various parameters related to acquisition of a selected

test. For 10GBASE-T, there are no acquisition parameters for any of
the selected tests.

Analyze Shows the various parameters related to analysis of a selected
test. These parameters can vary from one test to another test. For
example, the parameters shown for the Linearity measurement are
Start Frquency, Stop Frequency, and Resolution Bandwidth.

Limits Applies to a specific version. It shows the measurement lower and
upper limits using different types of comparisons like EQ(==), NE(!=),
GT(>), LT(<), GE(>=), LE(<=), GTLT(> <), GELT(>= <), GTLE(> <=),
LTGT(< >), LEGE(<= >=), LEGT(<= >), LTGE(< G=), GELE(>= <=).
Some use unary operands and some use binary operands. For unary
operands, only value1 (on the left) is active.

Comments You can specify a comment up to 256 characters long for selected test.
Restore Restores the default values.
Apply Applies the configuration parameters that you have set.
Close Dismisses the dialog box.
xxx
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Click Run in the Select panel to run the selected tests.

Refer to the following table for different test limit comparisons:

Table 14: Different test limit comparisons
Comparison string Description
EQ(==) Equal to
NE(!=) Not equal to
GT(>) Greater than
LT(<) Less than
GE(>=) Greater than or Equal to
LE(<=) Less than or Equal to
GTLT(><) Greater than and Less than
GELT(>=<) Greater than or equal to and Less than
GTLE(><=) Greater than and Less or equal to
LTGT(<>) Less than and Greater than
LEGE(<= >=) Less than or equal to and Greater than or equal to
LEGT(<= >) Less than or equal to and Greater than
LTGE(< >=) Less than and Greater than or equal to
GELE(>= =<) Greater than or equal to and Less than or equal to
xxx

Configure Acquire Panel
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You have the following options:

Restore load compliance mode values.

Change the parameters associated with analysis configuration.

Change the test limits in the User Defined mode.

Add comments for the selected measurement that would appear in the Report panel.

Configure Limits Panel
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Configure Analyze Panel
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View and Select Connected Instruments

Viewing Connected Instruments
The Tools > Instrument Bench menu item is used to discover connected instruments required for the
tests. The application uses TekVISA to discover the connected instruments. Once the operation is done,
the Instrument Bench dialog box resumes operation and lists the instrument-related details based on the
selected search criteria.

NOTE. When the TekVISA Instrument Manager checks for connected Instruments, the Instrument Bench
dialog box does not respond.

For example, if you select LAN and GPIB as the search criteria in the Instrument Bench dialog box and
click Refresh, the TekVISA Instrument Manager checks for the availability of instruments over LAN and
the details of the instruments are displayed under Retrieved Instruments table.

You can provide the time in the TekVISA Refresh Timeout (Seconds) field, within which if the TekVISA
Instrument Manager does not find the instruments, the TekExpress application resumes the operation. If
you choose Non-VISA resources, all the instruments supported by TekExpress but not communicating
over the VISA layer can be searched.
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Selecting Connected Instruments
You can view the instruments connected in the Configuration panel. The upper half of the panel displays
the general parameters for the tests under the selected test suite.

NOTE. The list of instruments displayed is specific to the selected test suite. It does not show all the
connected instruments.

Use Prerecorded Waveforms for Analysis
From the Acquire tab, you can see unique acquisitions, acquisition parameters, acquisition status, and
prerecorded waveform files of the selected test suite. The Acquire panel is specific to a suite and gets
updated every time the selected test suite is changed. This panel shows the acquisition details for the tests
in the currently selected suite. The tests with the common acquisition parameters are grouped together and
shown as a single acquisition.

NOTE. To use the prerecorded option, it is recommended that you use a waveform file (.wfm) which has
been captured from a Tektronix oscilloscope. This eliminates the need to use an oscilloscope. You can
manually select waveforms and in one-click on the Run button you can perform the measurements.
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Column name Function
Test Measurement Name of the tests performing acquisitions. One or more tests can perform

the same acquisitions.
Status Test acquisition status of the running test passed at intervals.
Waveform File Prerecorded waveform files of unique acquisitions. You can select

waveform files by clicking the hyperlink for example X:\XGbT-

10GBASE-T\10Sep730\DUT001\20090910_065259\ClockFre-

quency_Lane.wfm here. This allows you to select any waveform file using
the standard file open window.

xxx

The following Acquire source options are available:

Use Pre-recorded: Enabling or disabling the option shows or hides the waveform file column in
the acquisition table.

To know how to use the prerecorded waveform files for performing a measurement or the selected
test suite, click here.

Acquire Step by Step: Selecting this prompts you at the end of each acquisition before proceeding
to the next one.

When you select “Use Pre-recorded”, the first column shows the Test Measurement, the second column
shows the Status, and the next column shows the Waveform File for analysis.
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Use Acquire Live Waveform for Analysis
From the Acquire tab, you can see acquisition parameters, and acquisition status of the selected test suite.
The Acquire panel is specific to a suite and gets updated every time the selected test suite is changed. This
panel shows the acquisition details for the tests in the currently selected suite. The tests with common
acquisition parameters are grouped together and shown as a single acquisition.

Table 15: Button controls on the Acquire panel
Column name Function
Test Measurement Displays the name of the selected test and lane for

performing acquisitions. One or more tests can perform
the same acquisitions.

Status Acquisition status of the running test at intervals. The
messages are passed only in live acquisition.

Acquisition Updates the location of the acquisition name.
Acquire Source Options
Acquire Live Waveform When enabled, the lane selection is available.
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Table 15: Button controls on the Acquire panel (cont.)

Column name Function
Lane and Channel selection Select the lane. The channel selection is based on the

single-ended or differential source options.
Acquire Step By Step When enabled, displays the reference input waveform of

the selected measurement. This helps you to compare the
input waveform with the reference waveform, allows you to
change the setup before acquiring the waveforms, and then
proceeds with the next selected measurement.

xxx

View the Progress of Analysis
You can view the progress of the analysis in the Analyze panel. As the analysis of each test is complete,
the result value is updated.
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Analyze Table
The table contains the following:

The test name.

The status of the tests that are being run.

The tests that are not yet started are shown with a “To be Started” status. A summarized status of the
currently running test is shown in the Status Messages panel.

The Status Messages window time-stamps all run time messages and displays them. You can do the
following:

Display Status: Enable/Disable status messages.

Auto Scroll: Scroll the status messages automatically.

Clear All: Clear all status messages in Status Window.

Save Status: Save all status messages in text file. Displays a standard save file window and saves the
status messages in the user specified file.
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View the Report
After the analysis, a report is automatically generated and displayed in the report panel. The device
information such as oscilloscope model, serial number, firmware version of the oscilloscope, version
information of the TekExpress and the application, calibration status, start time, and the execution time are
displayed.

The panel shows a summary report of all the lanes and detailed report of each of the lanes - Lane A, Lane
B, Lane C, and Lane D. The details of the test such as the name, limit values, measured value with units,
pass/fail status, compliance mode, execution time, and additional information are displayed.

The Report View Area contains an HTML version of the report template. You can select any area of the
report and copy it to the clipboard to make it available to other application.

View Test Related Files
All the test related files for currently selected tests are always saved under: My Documents\My

TekExpress\XGbT–10GBASE-T\SessionName.

Case 1. An example image of data when the session is still not saved and is in the My
TekExpress/XGbT-10GBASE-T path as “Untitled Session”, the DUT ID is set to DUT001, and
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the tests are performed four times (four folders are created with the file naming convention YYYYMMDD_
HHMMSS (Date_Time).

Case 2. An example image of data when the session is still not saved and is in the My
TekExpress/XGbT-10GBASE-T path as “Untitled Session”, theDUT001 folder already present
(tests are performed six times), and the DUT ID is now set to DUT002 (here the tests are performed twice).

Case 3. An example image of data when the session is saved and is in the My TekExpress/XGbT-

10GBASE-T path as “Test”.
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Case 4. An example image of the test related files that are generated after performing the selected
measurements (report file, snapshot of the output waveforms for the selected measurements, input
waveform file for the selected measurements with the lane name used). These files are saved in the path My
Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session.
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Configure Droop Parameters
In the Configuration Panel, set the Ref Levels to either Absolute or Percentage. Set the MidLevel and
Hysteresis values of the signal for Droop measurement.

The limit and default values for MidLevel and Hysteresis parameters are listed in the following table:

Table 16: Default and limit configure values for MidLevel and Hysteresis parameters
Parameter Absolute Percentage

Minimum Maximum Default Minimum Maximum Default
MidLevel –10 V +10 V 0 V 20% 80% 50%
Hysteresis 0 V 2 V 0.05 V 2% 20% 5%
xxx

To configure the Droop parameters, enter a Start time, End time, and Population value for the signal in
the Droop parameter panel.

The limit and default value for these parameters are listed in the following table:

Table 17: Default and limit configure values for Droop measurement
Parameter Minimum Maximum Default
Start time 5 ns 15 ns 10 ns
End time 85 ns 95 ns 90 ns
Population 100 5000 1000
xxx

The population is the number of cycles considered for the droop measurement. The start and the end time
parameters are indicated in the following waveform.
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Configuration Panel to Set the Droop Parameters

Connections for Droop Measurement
Click here for information on connections for Droop measurement.

Configure the DUT and operate in transmitter test mode 6 to output the required waveforms.

Run the Droop Measurement
To run the Droop measurement in conformance with the 10GBASE-T standards, follow these steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the Droop measurement.

5. Click Configure to set the test parameters for the Droop measurement in the User Defined Mode.
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To set up the connections for Droop measurement, click Show Schematic and to view a snapshot of
the Droop signal, select Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze the live waveform or select
Use Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

8. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Droop measurement. This helps you to compare the applied input signal with the snapshot of a typical
Droop input signal, allowing you to change the setup before acquisition. The application then prompts
you to configure the DUT to transmit the Droop signal in the correct test mode and lane.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

9. Click Run.

10. The status of the measurement is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

11. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.
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Select Panel with Droop Measurement Selected
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Analyze Panel after Running Droop Measurement
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Report Panel after Running Droop Measurement
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Snapshot of the Droop Signal for Differential Source

Snapshot of the Droop Signal for Single-Ended Source
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Configure Power Spectral Density Parameters
In the Configuration Panel, set the PSD Start Frequency, PSD Stop Frequency, PSD Resolution Bandwidth,
Power Level Start Frequency, and Power Level Stop Frequency values of the signal for Power Spectral
Density measurement.

The limit and default values for these parameters are listed in the following table:

Table 18: Default and limit configure values for Power Spectral Density measurement
Parameter Description Minimum Maximum Default
PSD Start
Frequency

PSD curve is
measured from this
frequency

1 MHz 1.5 GHz 1 MHz

PSD Stop Frequency PSD curve is
measured upto this
frequency

1.6 GHz 4 GHz 3 GHz

PSD Resolution
Bandwidth

Based on this value,
the sample rate and
record length are set

1 MHz 5 MHz 1 MHz

Power Level Start
Frequency

Power Level is
measured from this
frequency

1 MHz 1.5 GHz 1 MHz

Power Level Stop
Frequency

Power Level is
measured upto this
frequency

1.6 GHz 4 GHz 3 GHz

xxx
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Configuration Panel to Set the Power Spectral Density Parameters

Connections for Power Spectral Density
Measurement

Click here for information on connections for Power Spectral Density measurement.

Configure the DUT and operate in transmitter test mode 5 to output the required waveforms.

Run the Power Spectral Density Measurement
To run the Power Spectral Density measurement in conformance with the 10GBASE-T standards, follow
these steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the Power Spectral Density measurement.
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5. Click Configure to set the test parameters for the Power Spectral Density measurement in the User
Defined Mode.

To set up the connections for Power Spectral Density measurement, click Show Schematic and to
view a snapshot of the Power Spectral Density signal, select Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

7. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Power Spectral Density measurement. The display helps you to compare the applied input signal with
the snapshot of a typical Droop input signal, allowing you to change the setup before acquisition.
The application then prompts you to configure the DUT to transmit the Power Spectral Density
measurement signal in the correct test mode and lane.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.

9. The status of the measurement is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

10. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.

NOTE. The Power Spectral Density test computes the transmitted power and checks if the power level
is within the limits of 3.2 dBm to 5.2 dBm. The application also checks if the Power Spectrum Density
measured with a 100 W load is within the specified upper and lower masks.
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Select Panel with Power Spectral Density Measurement Selected
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Analyze Panel after Running Power Spectral Density Measurement
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Report Panel after Running Power Spectral Density Measurement
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Snapshot of the Power Spectral Density Signal for Differential Source

Snapshot of the Power Spectral Density Signal for Single-Ended Source
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Configure Linearity Parameters
In the Configuration Panel, set the start frequency, stop frequency, and resolution bandwidth value of
the signal for Linearity measurement.

The limit and default values for these parameters are listed in the following table:

Table 19: Default and limit configure values for Linearity measurement
Parameter Description Minimum Maximum Default
Start Frequency SFDR is measured

by searching levels
from this frequency

1 KHz 30 MHz 1 MHz

Stop Frequency SFDR is measured
upto this frequency

350 MHz 800 MHz 400 MHz

Resolution
Bandwidth

Based on this value,
the sample rate and
record length are set

1 KHz 500 KHz 20 KHz

xxx
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Configuration Panel to Set the Linearity Parameters

Connections for Linearity Measurement
Click here for information on connections for Linearity measurement.

Configure the DUT and operate in transmitter test mode 4 to output the required waveforms.

Run the Linearity Measurement
To run the Linearity measurement in conformance with the 10GBASE-T standards, follow these steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the Linearity measurement with all the five tones selected by default. You have the option
to select one or more tones.
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NOTE. When using prerecorded waveform files for Linearity measurement with multiple tones selected,
ensure that waveform files corresponding to the selected tones are selected in the File > Open dialog
window.

5. Click Configure to set the test parameters for the Linearity measurement in the User Defined Mode.

To set up the connections for Linearity measurement, click Show Schematic and to view a snapshot of
the Linearity signal Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze the live waveform or select
Use Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

7. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Linearity Tone-1, input signal of the Linearity Tone-2, input signal of the Linearity Tone-3, input
signal of the Linearity Tone-4, and input signal of the Linearity Tone-5 measurement. This helps you
to compare the applied input signal with the snapshot of a typical Linearity input signal, allowing you
to change the setup before acquisition. The application then prompts you to configure the DUT to
transmit the Linearity signal in the correct test mode and also confirms if the lanes are connected
to the appropriate channels correctly.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.

NOTE. The application prompts you to set the appropriate test mode (for Linearity) and submode (for Tone
selection) before performing the measurement. The following two examples indicate that setting both the
test mode and submode correctly are important in performing the Linearity measurement:

1. To perform Linearity measurement on a Tone 2 signal, the application prompts you to set the mode to 4
and sub mode to 2. When you set them correctly, the measurement algorithm will identify the tone as Tone
2 and return the results appropriately.

2. To perform Linearity measurement on the Tone 2 signal, the application prompts you to set the mode to
4 and sub mode to 2. When you set them incorrectly (for example, test mode to 4 and sub mode to 1), the
measurement algorithm will identify the tone as a Tone 4 signal. Because there is a mismatch between the
measurement request and measurement signal sent as input, the result is shown as fail.

TekExpress XGbT-10GBASE-T Automated Solution 57



Application Examples Run the Linearity Measurement

9. The status of the measurement is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

10. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.

Select Panel with Linearity Measurement Selected
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Analyze Panel after Running Linearity Measurement

Report Panel after Running Linearity Measurement
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Snapshot of the Tone-1 Linearity Signal for Differential Source

Snapshot of the Tone-1 Linearity Signal for Single-Ended Source
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Snapshot of the Tone-2 Linearity Signal for Differential Source

Snapshot of the Tone-2 Linearity Signal for Single-Ended Source
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Snapshot of the Tone-3 Linearity Signal for Differential Source

Snapshot of the Tone-3 Linearity Signal for Single-Ended Source
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Snapshot of the Tone-4 Linearity Signal for Differential Source

Snapshot of the Tone-4 Linearity Signal for Single-Ended Source
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Snapshot of the Tone-5 Linearity Signal for Differential Source

Snapshot of the Tone-5 Linearity Signal for Single-Ended Source
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Configure Clock Frequency Parameters
In the Configuration Panel, set the Ref Levels to either Absolute or Percentage. Set the MidLevel and
Hysteresis values of the signal for Clock Frequency measurement.

The limit and default values for MidLevel and Hysteresis parameters are listed in the following table:

Table 20: Default and limit configure values for Clock Frequency
Parameter Absolute Percentage

Minimum Maximum Default Minimum Maximum Default
MidLevel 0 V +10 V 0 V 20% 80% 50%
Hysteresis 0 V 2 V 0.05 V 2% 20% 5%
xxx

Configuration Panel to Set the Clock Frequency Parameters

Connections for Clock Frequency
Measurement

Click here for information on connections for Clock Frequency measurement.

Configure the DUT and operate in transmitter test mode 2 to output the required waveforms.
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Run the Clock Frequency Measurement
To run the Clock Frequency measurement in conformance with the 10GBASE-T standards, follow these
steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the Clock Frequency measurement.

5. Click Configure to set the test parameters for the Clock Frequency measurement in the User Defined
Mode.

6. To set up the connections for Clock Frequency measurement, click Show Schematic and to view a
snapshot of the Clock Frequency signal Click to view image of the waveform.

7. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

8. In the Acquire panel, click Acquire Step By Step displays a snapshot of the input signal of the Clock
Frequency measurement. This helps you to compare the applied input signal with the snapshot of a
typical Clock Frequency input signal, allowing you to change the setup before acquisition. The
application then prompts you to configure the DUT to transmit the Clock Frequency signal in the
correct test mode and lane.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

9. Click Run

10. The status of the measurements is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

11. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)
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NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.

Select Panel with Clock Frequency Measurement Selected
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Analyze Panel after Running Clock Frequency Measurement
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Report Panel after Running Clock Frequency Measurement
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Snapshot of the Clock Frequency Signal for Differential Source

Snapshot of the Clock Frequency Signal for Single-Ended Source
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Configure Jitter-Master Parameters
In the Configuration Panel, set the Ref Levels to either Absolute or Percentage. Set the MidLevel and
Hysteresis values of the signal for Jitter-Master measurement.

You have the option to apply filter corresponding to the sampling frequency, the filter is not applied
by default.

NOTE. An appropriate filter available for each oscilloscope is applied to the input waveform. The output
of the filter is then computed for the jitter.

The limit and default values for MidLevel and Hysteresis parameters are listed in the following table:

Table 21: Default and limit configure values for Jitter-Master measurement
Parameter Absolute Percentage

Minimum Maximum Default Minimum Maximum Default
MidLevel –10 V +10 V 0 V 20% 80% 50%
Hysteresis 0 V 2 V 0.05 V 2% 20% 5%
xxx
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Configuration Panel to Set the Jitter-Master Parameters

Connections for Jitter-Master Measurement
Click here for information on connections for Jitter-Master measurement.

Configure the DUT and operate in transmitter test mode 2 to output the required waveforms.

Run the Jitter-Master Measurement
To run the Jitter-Master measurement in conformance with the 10GBASE-T standards, follow these steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the Jitter-Master measurement.

5. Click Configure to set the test parameters for the Jitter-Master measurement in the User Defined Mode.
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To set up the connections for Jitter-Master measurement, click Show Schematic and to view a
snapshot of the Jitter-Master signal, select Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

7. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Jitter-Master measurement. This helps you to compare the applied input signal with the snapshot of a
typical Jitter-Master input signal, allowing you to change the setup before acquisition. The application
then prompts you to configure the DUT to transmit the Jitter-Master signal in the correct test mode.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.

9. The status of the measurements is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

10. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.
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Select Panel with Jitter-Master Selected
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Analyze Panel after Running Jitter-Master Measurement
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Report Panel after Running Jitter-Master Measurement
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Snapshot of the Jitter-Master Signal for Differential Source

Snapshot of the Jitter-Master Signal for Single-Ended Source
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Configure Jitter-Slave Parameters
In the Configuration Panel, set the Ref Levels to either Absolute or Percentage. Set the MidLevel and
Hysteresis values of the signal for Jitter-Slave measurement.

You have the option to apply filter corresponding to the sampling frequency, the filter is not applied
by default.

NOTE. An appropriate filter available for each oscilloscope is applied to the input waveform. The output
of the filter is then computed for the jitter.

The limit and default values for MidLevel and Hysteresis parameters are listed in the following table:

Table 22: Default and limit configure values for Jitter-Slave measurement
Parameter Absolute Percentage

Minimum Maximum Default Minimum Maximum Default
MidLevel –10 V +10 V 0 V 20% 80% 50%
Hysteresis 0 V 2 V 0.05 V 2% 20% 5%
xxx
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Configuration Panel to Set the Jitter-Slave Parameters

Connections for Jitter-Slave Measurement
Click here for information on connections for Jitter-Slave measurement.

Configure the DUT and operate in transmitter test mode 2 to output the required waveforms.

Run the Jitter-Slave Measurement
To run the Jitter-Slave measurement in conformance with the 10GBASE-T standards, follow these steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select Lane D.

3. Enter the DUT ID.

4. Select the Jitter-Slave measurement.

5. Click Configure the test parameters for the Jitter-Slave measurement in the User Defined Mode.
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To set up the connections for Jitter-Slave measurement, click Show Schematic and to view a snapshot
of the Jitter-Slave signal, select Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

7. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Jitter-Slave measurement. This helps you to compare the applied input signal with the snapshot of a
typical Jitter-Slave input signal, allowing you to change the setup before acquisition. The application
then prompts you to configure the DUT to transmit the Jitter-Slave signal in the correct test mode.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.

9. The status of the measurements is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

10. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.
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Select Panel with Jitter-Slave Selected
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Analyze Panel after Running Jitter-Slave Measurement
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Report Panel after Running Jitter-Slave Measurement
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Snapshot of the Jitter-Slave Signal for Differential Source

Snapshot of the Jitter-Slave Signal for Single-Ended Source
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Configure Return Loss Parameters
In the Configuration Panel, set the Acquisition Averages and Smooth Averaging values of the signal
for Return Loss measurement.

NOTE. You cannot configure the Return Loss parameters.

The limit and default values are listed in the following table:

Table 23: Default and limit configure values for Acquisition Averages and Smooth Averaging parameters
Values

Parameter
Minimum Maximum Default

To do

Acquisition
Averages

100 200 100 Enter the number of waveforms you want to
average.

Smooth
Averaging

0 10 5 Enter the smoothening factor.

xxx

TekExpress XGbT-10GBASE-T Automated Solution 85



Application Examples Connections for Return Loss Measurement

Connections for Return Loss Measurement
Click here for steps and connections for performing the Return Loss measurement.

Configure the DUT and operate in transmitter test mode 4 to output the required waveforms.

Calibration for Return Loss Measurement
Perform the following steps for calibration of the Return Loss measurement:

1. For setting up the AWG and the oscilloscope, click here for the steps.

2. Click Live Calibration or Use Files.

NOTE. Use the TC3 of the test fixture.
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Run the Return Loss Measurement
To run the Return Loss measurement in conformance with the 10GBASE-T standards, follow these steps:

1. In the Select panel, select Differential as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the Return Loss measurement.

NOTE. To ensure that the selected lane is calibrated at least once before performing the measurement,
the application prompts you to either run calibration or deselect the measurement. See the set up for the
calibration of the measurement.

5. To set up the connections for Return Loss measurement, click Show Schematic and to view a snapshot
of the Return Loss signal, select Click to view image of the waveform.

NOTE. You cannot configure the Return Loss parameters.

NOTE. While performing the measurement, ensure that you connect the CAT5 cable to the DUT.

6. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files for Return Loss measurement, ensure to point to the
appropriate location of the calibration files for the selected lane using “Use Files” dialog box.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

7. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Return Loss measurement. This helps you to compare the applied input signal with the snapshot of a
typical Return Loss input signal, allowing you to change the setup before acquisition. The application
then prompts you to configure the DUT to transmit the Return Loss signal in the correct test mode.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.
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9. The status of the measurements is displayed in the Analyze panel. To view the pass or fail status for
each of the measurements, click Show Pass/Fail.

10. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.

Select Panel when Selecting the Return Loss Measurement
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Snapshot of the Return Loss Signal for Differential Source

Analyze Panel after Running Return Loss Measurement
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Report Panel after Running Return Loss Measurement

Run Multiple Measurements on a Single Lane
To run multiple measurements in conformance with the 10GBASE-T standards, follow these steps:

1. Select Differential or Single Ended as the source.

2. Select one of the test lanes.

3. Enter the DUT ID.

4. Select the measurements.

5. Click Configure to set the test parameters for each of the selected measurements in the User Defined
Mode.

To set up the connections for each of the selected measurements, click Show Schematic and to view a
snapshot of the signal, select Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.
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7. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of the
Droop measurement. This helps you to compare the applied input signal with the snapshot of a typical
Droop input signal, allowing you to change the setup before acquisition. The application then prompts
you to configure the DUT to transmit the Droop signal in the correct test mode and lane.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.

The application then prompts you to configure the DUT to transmit the selected measurement signals
in the correct test modes and if the lane is connected to the appropriate channel correctly.

9. The status of the selected measurements is displayed in the Analyze panel.

10. After the measurements run successfully, the results are displayed in the Report panel. The reports
are automatically saved in MHT format to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.
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Select Panel with Multiple Measurements Selected
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Analyze Panel after Running Multiple Measurements
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Report Panel after Running Multiple Measurements

Run One or More Measurements on Multiple
Lanes

To run one or more measurements on multiple lanes in conformance with the 10GBASE-T standards,
follow these steps:

1. Select Differential or Single Ended as the source.

2. Select two or more test lanes.

3. Enter the DUT ID.

4. Select the measurements.

5. Click Configure to set the test parameters for each of the selected measurements in the User Defined
Mode. To set up the connections for each of the selected measurements, click Show Schematic and to
view a snapshot of the signal, select Click to view image of the waveform.

6. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

94 TekExpress XGbT-10GBASE-T Automated Solution



Application Examples Run One or More Measurements on Multiple Lanes

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

7. When enabled, Acquire Step By Step displays the input signal of the selected measurement. This
helps you to compare the applied input signal with the snapshot of a typical input signal for the
selected measurement, allowing you to change the setup before acquisition, and then proceeds to the
next selected measurement. This is repeated for each of the selected measurements.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

8. Click Run.

The application then prompts you to configure the DUT to transmit the selected measurement signals in
the correct test modes and lanes correctly. You can have different conditions depending on the probe,
lane, and channel setting as follows:

Table 24: Examples of using one or more probes
Condi-
tion Lane A Lane B Lane C Lane D Description
Using Four Probes
1 CH1 CH2 CH3 CH4 A popup window appears where you can set the

correct test mode, channel (CH1) on the selected
lane (Lane A), channel (CH2) on the selected lane
(Lane B), channel (CH3) on the selected lane
(Lane C), and channel (CH4) on the selected lane
(Lane D) for each of the selected measurements.

Using Two Probes
1 CH1 CH2 A popup window appears where you can set

the correct test mode, channel (CH1) on the
selected lane (Lane A), and channel (CH2) on the
selected lane (Lane B) for each of the selected
measurements.

2 CH1 CH2 CH1 A popup window appears where you can set
the correct test mode, channel (CH1) on the
selected lane (Lane A), and channel (CH2) on the
selected lane (Lane B) for each of the selected
measurements.
Another popup window appears where you can
set the correct test mode and set the channel
(CH1) on Lane C for each of the selected
measurements.
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Table 24: Examples of using one or more probes (cont.)

Condi-
tion Lane A Lane B Lane C Lane D Description
3 CH1 CH2 CH1 CH2 A popup window appears where you can set

the correct test mode, channel (CH1) on the
selected lane (Lane A), and channel (CH2) on the
selected lane (Lane B) for each of the selected
measurements.
Another popup window appears where you can
set the correct test mode, channel (CH1) on the
selected lane (Lane C), and channel (CH2) on the
selected lane (Lane D) for each of the selected
measurements.

Using One Probe
1 CH1 CH1 A popup window appears where you can set the

correct test mode and channel (CH1) on lane A
for each of the selected measurements.
Another popup window appears where you can
set the correct test mode and channel (CH1) on
lane B for each of the selected measurements.

xxx

9. The status of the selected measurements is displayed in the Analyze panel.

10. After the measurements run successfully, the results are displayed in the Report panel. The reports
are automatically saved in MHT format to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\<DU-

TID>\<DATE>(YYYYMMDD)_<TIME>(HHMMSS)

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.
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Popup Window that Appears for the Selected Measurement on Lane A (Channel 1), Lane B
(Channel 2), Lane C (Channel 3), and Lane D (Channel 4)

Popup Window that Appears for the Selected Measurement on Lane A (Channel 1)
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Popup Window that appears for the Selected Measurement on Lane B (Channel 1)

Popup Window that Appears for the Selected Measurement on Lane A (Channel 1) and Lane B
(Channel 2)
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Popup Window that Appears for the Selected Measurement when Lane A (Channel 1) and
Lane B (Channel 2)

Popup Window that Appears for the Selected Measurement on Lane C (Channel 1)
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Popup Window that Appears for the Selected Measurement when Lane A (Channel 1) and
Lane B (Channel 2)

Popup Window that Appears for the Selected Measurement when Lane C (Channel 1) and
Lane D (Channel 2)
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Select Panel with One or More Measurements Selected
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Analyze Panel after Running Multiple Measurement on Multiple Lanes
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Report Panel after Running Multiple Measurement on Multiple Lanes

Automate DUT Operation
To run the selected measurements in conformance with the 10GBASE-T standards using USB MPC
Device for DUT automation, follow these steps:

1. In the Select panel, select Differential or Single Ended as the source.

2. Select the test lanes.

3. Enter the DUT ID.

4. Set up for the DUT automation of the selected tests, click here.

5. In the DUT Automation panel, select Using MDIO to automate the test mode set up for each of
the selected measurements.

NOTE. Ensure that the drivers for the USB MPC device are installed. When the standard Windows dialog
“New hardware found” is displayed, follow the on-screen instructions to complete the installation.

An error message is displayed when selecting Using MDIO the first time after launching the application
or when the driver is not installed.

6. Select the measurements.
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7. Click Configure in the Select panel to set up the configuration parameters for each of the selected
measurements.

To set up the connections for each of the selected measurement, click Show Schematic and to view a
snapshot of the Droop signal, select Click to view image of the waveform.

8. In the Acquire panel, select either Acquire Live Waveform to analyze live waveform or select Use
Pre-recorded to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report panel are not available
after the measurement is run.

9. In the Acquire panel, click Acquire Step By Step to display a snapshot of the input signal of each the
selected measurements. This helps you to compare the applied input signal with the snapshot of a
typical input signal, allowing you to change the setup before acquisition.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option is not available.

10. Click Run.

11. The status of the measurements is displayed in the Analyze panel.

12. After the measurement runs successfully, a summary report of all lanes and detailed report of each
of the lanes are displayed in the Report panel. The reports are automatically saved in MHT format
to the default location:

X:\XGbT-10GBASE-T\Untitled Session\DUTID\DATE\(YYYYMMDD)_(HHMMSS)

or

My Documents\My TekExpress\XGbT–10GBASE-T\Untitled Session\DUTID\<DATE>(YYYYM-
MDD)_<TIME>(HHMMSS).

NOTE. After a measurement is complete and a report is generated, if you select File > Save Report
As and save the file in MHT format a blank .mht file is created at the target location. This is a known
problem and happens because of an issue with Internet Explorer. Instead copy the generated .mht file to a
different location manually.
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Select Panel
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DUT Automation Panel

Set Up for DUT Automation

Perform Live Calibration for Return Loss
Measurement

NOTE. Ensure that atleast one lane is selected for calibration.
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Select the test lanes and click Tools > Return Loss Calibration or Calibrate button in the test
measurement Select panel. A Return Loss Calibration dialog box is displayed. Click Live Calibration to
perform calibration as follows:

1. Select a channel for each of the probes.

2. Click View SetupDiagram to view and configure the test fixture (connect CAT5 cable to J20 of
TC3 and J28 on the daughter board to the Short slot) and click Run for acquiring data with Short
calibration on the selected lane. A Return Loss Calibration: Run Short dialog box appears displaying
the reference waveform for Short calibration. To complete the calibration, run the Short calibration
again. Initially the status of Short calibration appears as Not Run. Once the calibration is done the
status changes to Completed and the Run button changes to Re-Run.
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Typical Waveform for Return Loss Short Calibration

3. Click View SetupDiagram to view and configure the test fixture (connect CAT5 cable to J20 of TC3
and J30 on the daughter board to the Load slot) and click Run for acquiring data with Load calibration
on the selected lane. A Return Loss Calibration: Run Load dialog box appears displaying the reference
waveform for Short calibration. To complete the calibration, run the Short calibration again, and
cancel the current calibration. Initially the status of Load calibration appears as Not Run. Once the
calibration is done the status changes to Completed and the Run button changes to Re-Run.

4. Click View SetupDiagram to view and configure the test fixture (connect CAT5 cable to J20 of
TC3 and J30 on the daughter board to the Open slot) and click Run for acquiring data with Open
calibration on the selected lane. A Return Loss Calibration: Run Open dialog box appears displaying
the reference waveform for Open calibration. To complete the calibration, run the Short calibration
again, and cancel the current calibration. Initially the status of Open calibration appears as Not Run.
Once the calibration is done the status changes to Completed and the Run button changes to Re-Run.
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5. Do one of the following:

Click Apply Calibration to apply these calibrated values to perform the Return Loss measurement.

Connect the CAT5 cable to J20 of TC3 and J30 on the daughter board to the Open slot. Click Verify
for acquiring data on the selected lane and validating the Short, Load, and Open calibration values.
Apply the calibrated values to perform the Return Loss measurement. A Return Loss Calibration: Run
Verify dialog box appears displaying the reference waveform for Verify calibration. Initially the status
of Verify calibration appears as Not Run, once the calibration is done the status changes to Completed.

Click Cancel to exit calibration.

6. For multiple lanes, the Return Loss Calibration dialog box appears again for each of selected lanes to
either perform the live calibration (Step 1) or to cancel the calibration.
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Typical Waveform for Return Loss Load Calibration
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Typical Waveform for Return Loss Open Calibration
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Typical Waveform for Return Loss Verify Calibration

Use Calibration Files for Return Loss
Measurement

Select the test lanes and click Tools > Return Loss Calibration or Calibrate button in the test
measurement Select panel. A Return Loss Calibration dialog box is displayed. Click Use Files to use the
calibration files of the earlier calibration and perform the Return Loss measurement.
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1. Select a channel for each of the probes.

2. Click Browse to select the directory where calibration files for this lane are saved.

NOTE. Make sure all the calibration files of Short, Load, and Open configuration are available in the
selected directory.
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3. Do one of the following:

ClickApply Calibration to apply these calibrated values to perform the Return Loss measurement.

Click Verify to validate the Short, Load, and Open calibration values and then apply the calibrated
values to perform the measurement. Initially the status of Verify calibration appears as Not Run.
Once the calibration is done the status changes to Completed.

Click Live Calibration to perform a new live calibration.

Click Cancel to exit calibration.

4. For multiple lanes, the Return Loss Calibration dialog box appears again for each of selected lanes to
either perform the live calibration (Step 1) or use the existing calibrated files (Step 1).
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Connection Setup

Connections with SMA Probe (Differential Source)
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1. Connect the DUT to the TC1 of the TF-XGbT test fixture.

2. Connect the positive and negative points of the test fixture to the configured oscilloscope channel
using the SMA probe.

3. Configure the source DUT in the correct test mode to output the required waveforms.

Connection with a Differential Probe (Differential Source)
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1. Connect the DUT to the TC1 of the TF-XGbT test fixture.

2. Connect the positive and negative points of the test fixture to the configured oscilloscope channel using
a differential P7350 probe.

3. Configure the source DUT in the correct test mode to output the required waveforms.

Connections with SMA Cables (Single-Ended Source)
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1. Connect the DUT to the TC1 of the TF-XGbT test fixture.

2. Connect the positive and negative points of the test fixture to the configured oscilloscope channel
using the SMA cables.

3. Configure the source DUT in the correct test mode to output the required waveforms.

Performing Analysis Using Prerecorded
Waveforms

1. Open the session that you have saved using File > Open Session or File > Recently Recalled Setup
(a recent file). A drop-down box appears showing the session name with the date details.

2. Select Use Pre-recorded in the Acquire panel and select one of the sessions listed in the drop-down
box.

3. You can modify the waveform file for each lane of the measurements, add or delete a lane, and even add
or delete a new measurement to the existing test suite. Once you select run, data corresponding for that
run is populated (such as the selected test, the test configuration settings, and the test summary status).

To perform analysis using prerecorded waveform file, click here to view the steps.

Perform Analysis Using Prerecorded Waveform File
1. Create a new session, click File > New Session.

2. Select a measurement in the Select panel.

3. Save the session, click File > Save Session.

4. In the Acquire panel, select Use Pre-recorded and browse to the location where the prerecorded
waveform file is located.

5. Click Run.
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Connection Setup for Jitter-Slave

Connections with SMA Probe (Differential Source) for Jitter-Slave Measurement
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1. Connect the DUT to the TC2 of the TF-XGbT test fixture.

2. Connect the positive and negative points of the test fixture to the configured oscilloscope channel
using the SMA probe.

3. Configure the source DUT in the correct test mode to output the required waveforms.

Connection with a Differential Probe (Differential Source) for Jitter-Slave Measurement
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1. Connect the DUT to the TC2 of the TF-XGbT test fixture.

2. Connect the positive and negative points of the test fixture to the configured oscilloscope channel using
a differential P7350 probe.

3. Configure the source DUT in the correct test mode to output the required waveforms.

Connections with SMA Cables (Single-Ended Source) for Jitter-Slave Measurement
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1. Connect the DUT to the TC2 of the TF-XGbT test fixture.

2. Connect the positive and negative points of the test fixture to the configured oscilloscope channel
using the SMA cables.

3. Configure the source DUT in the correct test mode to output the required waveforms.

Connection Setup for Return Loss
The Steps and connections for performing the Return Loss measurement are as follows:

1. Connect the oscilloscope and the AWG instrument as shown in the following rear view diagram:

2. Check if the LAN ports are ON for both the oscilloscope and the AWG (only if the connectivity
between AWG and oscilloscope is via LAN).

NOTE. The connectivity between AWG and oscilloscope can also be via LAN.

3. In the oscilloscope, select Utilities > GPIB Configuration... > Controller.

4. In the AWG instrument, select System > GPIB/LAN Configuration > Talk/Listener.
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5. In the XGbT application, select Tools > Instrument Bench and verify that the connected AWG
instrument is listed.

6. Once the connection between the AWG and oscilloscope is established, make the connections as
follows:
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NOTE. is used to denote short jumpers.
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7. Connect the DUT to the TC3 of the TF-XGbT test fixture.

8. Connect the positive and negative points of the test fixture to the configured oscilloscope channel using
a differential P7350 probe.

9. Configure the source DUT in the correct test mode to output the required waveforms.

Setting up the AWG and the Oscilloscope for
Calibration

Follow these steps to set up the AWG and the oscilloscope for calibration of the Return Loss measurement
are as follows:

1. Connect the oscilloscope and the AWG instruments as shown in the following rear view diagram:

NOTE. The GPIB port on DPO7K Series is on the side of the instrument.

2. Check if the LAN ports are ON for both the oscilloscope and the AWG (only if the connectivity
between AWG and Oscilloscope is via LAN).

NOTE. The connectivity between AWG and oscilloscope can also be via LAN.

3. In the oscilloscope, select Utilities > GPIB Configuration... > Controller.
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4. In the AWG instrument, select System > GPIB/LAN Configuration > Talk/Listener.

5. In the XGbT application, select Tools > Instrument Bench and verify that the connected AWG
instrument is listed.

6. Once the connection between the AWG and oscilloscope is established, make the connections as
follows:
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NOTE. is used to denote short jumpers.
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7. Connect an SMA cable to the AWG Analog channel of Arbitrary Waveform Generator and J21 of
test fixture.

8. Connect another SMA cable to the AWG Analog channel of Arbitrary Waveform Generator and
J26 of test fixture.

9. Connect another SMA cable to Marker 1/ Sync of AWG to Aux In of the oscilloscope.

10. To test Lane A, B, C, or D connect the differential probes to configured channels of the oscilloscope
and positive and negative points of the test fixture as shown in the calibration setup diagram.
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About the Programmatic Interface
Related Topics

Server and Client Proxy Objects

The Programmatic interface allows you to seamlessly integrate the TekExpress test automation application
with the high-level automation layer. This also allows you to control the state of TekExpress application
running on a local or a remote computer.

For simplifying the descriptions, the following terminologies are used in this section:

TekExpress Client: A High level automation application that communicates with TekExpress using
TekExpress Programmatic Interface.

TekExpress Server: The TekExpress application when being controlled by TekExpress Client.

TekExpress leverages .Net Marshalling to enable the Programmatic Interface for TekExpress Client.
TekExpress provides a client library for TekExpress clients to use the programmatic interface. The
TekExpress client library is inherited from .Net MarshalByRef class to provide the proxy object for the
clients. The TekExpress client library maintains a reference to the TekExpress Server and this reference
allows the client to control the server state.
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Click the following links to get details on them:

What does one need to have to develop TekExpress Client ?

While developing TekExpress Client one needs to use the TekExpressClient.dll. The client can be a VB
.Net, C# .Net, TestStand or web application. The examples for interfaces in each of these applications
are in Samples folder.

References required
TekExpressClient.dll has internal reference to IIdlglib.dll and IRemoteInterface.dll.

IIdlglib.dll has a reference to TekDotNetLib.dll.

IRemoteInterface.dll provides the interfaces required to perform the remote automations. It is an interface
that forms the communication line between the server and the client.

IIdlglib.dll provides the methods to generate and direct the secondary dialog messages at the client-end.

NOTE. The end-user client application does not need any reference to above mentioned DLL files. It is
essential to have these DLLs (IRemoteInterface.dll, IIdlglib.dll and TekDotNetLib.dll) in same folder
location as that of TekExpressClient.dll.

What steps does a client need to follow ?

The following are the steps that a client needs to follow to use the TekExpressClient.dll to programmatically
control the server:

A client UI must be developed to access the interfaces exposed through the server. This client needs to
load TekExpressClient.dll to access the interfaces. Once the TekExpressClient.dll is loaded, the
client UI can call the specific functions to run the operations requested by the client. Once the client is
up and running, it must do the following to run a remote operation:

1. The client needs to provide the IP address of the PC at which the server is running in order to connect
to the server.

2. The client needs to lock the server application to avoid conflict with any other Client that may try to
control the server simultaneously. “Lock” would also disable all user controls on server so that server
state cannot be changed by manual operation.

3. If any other client tries to access a server which is locked, it will get a notification that the server
is locked by another client.

4. When the client has connected to and locked the server, the client can access any of the programmatic
controls to run the remote automations.
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5. Once the client operations are completed, the server needs to be “unlocked” by the client.

Server and Client Proxy Objects

Remote Proxy Object
The server exposes a remote object to let the remote client access and perform the server side operations
remotely. The proxy object is instantiated and exposed at the server-end through marshalling.

The following is an example:

RemotingConfiguration.RegisterWellKnownServiceType (typeof (TekExpressRe-

moteInterface), “TekExpress Remote interface”, WellKnownObjectMode.Singleton);

This object lets the remote client access the interfaces exposed at the server side. The client gets the
reference to this object when the client gets connected to the server.

For example,

//Get a reference to the remote object

remoteObject = (IRemoteInterface)Activator.GetObject(typeof(IRemoteInterface),

URL.ToString());
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Client Proxy Object
Client exposes a proxy object to receive certain information.

For example,

//Register the client proxy object

WellKnownServiceTypeEntry[] e = RemotingConfiguration.GetRegisteredWell-

KnownServiceTypes();

clientInterface = new ClientInterface();

RemotingConfiguration.RegisterWellKnownServiceType(typeof(ClientInterface),

“Remote Client Interface”, WellKnownObjectMode.Singleton);

//Expose the client proxy object through marshalling

RemotingServices.Marshal(clientInterface, "Remote Client Inteface");

The client proxy object is used for the following:

1. To get the secondary dialog messages from the server.

2. To get the file transfer commands from the server while transferring the report.

Click here to see examples.

clientObject.clientIntf.DisplayDialog(caption, msg,iconType, btnType);

clientObject.clientIntf.TransferBytes(buffer, read, fileLength);
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To know more on the topics below, click the links.

Secondary Dialog Message Handling

The secondary dialog messages from the Secondary Dialog library are redirected to the client-end when a
client is performing the automations at the remote end.

In the secondary dialog library, the assembly that is calling for the dialog box to be displayed is checked
and if a remote connection is detected, the messages are directed to the remote end.

File Transfer Events

When the client requests the transfer of the report, the server reads the report and transfers the file by
calling the file transfer methods at the client-end.

Client Programmatic Interface: An Example
An example of the client programmatic interface is described and shown as follows:
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1. Connect to a server or remote object using the programmatic interface provided.

2. Get the client ID that is created when connecting to the remote object. This client ID is one of the
required parameters to communicate with the server.

NOTE. Server identifies the client with this ID only and rejects any request if the ID is invalid.

3. Lock the server for further operations. This disables the application interface.

NOTE. You can get values from the server or set values from the server to the client only if application is
locked.

4. Register for receiving notifications on status change events on the server. To register you need to
give a handler as a parameter.

NOTE. Whenever there is a change in the status of the server, all the clients registered with the server
receive a notification from the server.

5. Select the tests that you want to run through the programmatic interface.

6. Set the necessary parameters for each test.

7. Run the tests.

8. Poll for the status of the application.

NOTE. You can skip this step if you are registered for the status change notification and when the status is
Ready.

9. After completing the tests, get the results.

10. Create a report or display the results and verify or process the results.

11. Unlock the server once you complete all the tasks.

12. Disconnect from the remote object.

Handler of Status Change Notification
1. Get the status. If the status is Wait or Error, get the information which contains the title, message

description, and the expected responses for the status.

2. Perform the actions based on the status information.

3. Set the response as expected.
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XGbT Application Command Arguments and
Queries

Connect through an IP address

Lock the server

Disable the popups

Set or get the DUT ID

Set the configuration parameters for a suite or measurement

Query the configuration parameters for a suite or measurement

Select a measurement

Select a suite

Run with set configurations or stop the run operation

Handle Error Codes

Get or set the timeout value

Wait for the test to complete

After the test is complete

Save, recall, or check if a session is saved

Unlock the server

Disconnect from server

string id

Name Type Direction Description
id string IN Identifier of the client that is

performing the remote function.
xxx

Ready: Test configured and ready to start.

Running: Test running.

Paused: Test paused.

Wait: A popup that needs your inputs.

Error: An error is occurred.
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string dutName

Name Type Direction Description
dutName string IN The new DUT ID of the setup.
xxx

out bool saved

Name Type Direction Description
saved bool OUT Boolean representing whether the

current session is saved.
xxx

This parameter is used as a check in SaveSession() and SaveSessionAs() functions.

string ipAddress

Name Type Direction Description
ipAdress string IN The ip address of the server to which the client

is trying to connect to. This is required to
establish the connection between the server
and the client.

xxx

out string clientID

Name Type Direction Description
clientid String OUT Identifier of the client that is connected to the

server.
clientId = unique number + ipaddress of the
client. For example, 1065–192.157.98.70

xxx

NOTE. If the dutName parameter is null, the client is prompted to provide a valid DUT ID.

NOTE. The server must be active and running for the client to connect to the server. Any number of
clients can be connected to the server at a time.

NOTE. When the client is disconnected, it is unlocked from the server and then disconnected. The id
is reused.
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string dutId

Name Type Direction Description
dutId string OUT The DUT ID of the setup.
xxx

The dutId parameter is set after the server processes the request.

string device

Name Type Direction Description
device string IN Specifies the name of the device.
xxx

string suite

Name Type Direction Description
suite string IN Specifies the name of the suite.
xxx

string test

Name Type Direction Description
test string IN Specifies the name of the test to

obtain the pass or fail status.
xxx

string parameterString

Name Type Direction Description
parameterString string IN Selects or deselects a test.
xxx

int rowNr

Name Type Direction Description
rowNr int IN Specifies the zero based row index of

the sub-measurement for obtaining
the result value.

xxx

NOTE. When the client tries to lock a server that is locked by another client, the client gets a
notification that the server is already locked and it must wait until the server is unlocked. If the client
locks the server and is idle for a certain amount of time then the server is unlocked automatically
from that client.
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out string[] status

Name Type Direction Description
status string array OUT The list of status messages generated

during run.
xxx

string name

Name Type Direction Description
name string IN The name of the session being

recalled.
xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

NOTE. When the run is performed, the status of the run is updated periodically using a timer.

string name

Name Type Direction Description
name string IN The name of the session being

saved.
xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

Once the session is saved under ‘name’ you cannot use this method to save the session in a different
name. Use SaveSessionAs instead.

string name

Name Type Direction Description
name string IN The name of the session being

recalled.
xxx

The same session is saved under different names using this method. The name parameter cannot be
empty. If it is empty, the client is prompted to provide a valid name.

bool isSelected

Name Type Direction Description
isSelected bool IN Selects or deselects a test.
xxx
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string time

Name Type Direction Description
time string IN The time in seconds

which refers to the timeout
period.

xxx

The time parameter gives the timeout period, that is the time the client is allowed to be locked and
idle. After the timeout period if the client is still idle, it gets unlocked.

The time parameter should be a positive integer. Else, the client is prompted to provide a valid
timeout period.

bool_verbose

Name Type Direction Description
_verbose bool IN Specifies whether thec verbose mode

should be turned ON or OFF.
xxx

NOTE. When the session is stopped, the client is prompted to stop the session and is stopped at
the consent.

string filePath

Name Type Direction Description
filePath string IN The location where the report must

be saved in the client.
xxx

NOTE. If the client does not provide the location to save the report, the report is saved at
C:\ProgramFiles.

NOTE. When the client is disconnected, the client is automatically unlocked.

out string caption

Name Type Direction Description
caption String OUT The wait state or error state message sent to

you.
xxx
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out string message

Name Type Direction Description
message String OUT The wait state /error state message to you.
xxx

out string[] buttonTexts

Name Type Direction Description
buttonTexts string array OUT An array of strings containing the

possible response types that you can
send.

xxx

string response

Name Type Direction Description
response string IN A string containing the response

type that you can select (it must be
one of the strings in the string array
buttonTexts).

xxx

out string clientID

Name Type Direction Description
clientID String OUT Identifier of the client that is connected to the

server.
clientID = unique number + ipaddress of the
client. For example, 1065–192.157.98.70

xxx
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Connect Through an IP Address
Table 25: Connect through an IP address
Command name Parameters Description Return Value Example
Connect() string

ipAddress
out string
clientID

This method
connects the client
to the server.
Note
The client provides
the IP address
to connect to the
server.
The server
provides a unique
client identification
number when
connected to it.

Return value is
either True or
False.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as boolean
returnval = m_Client.Con-
nect(ipaddress,m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Lock the Server
Table 26: Lock the server
Command name Parameters Description Return Value Example
LockSession() string clientID This method locks

the server.
Note
The client must
call this method
before running
any of the remote
automations. The
server can be
locked by only one
client.

String value that
gives the status
of the operation
after it has been
performed.
The return value
is "Session
Locked...” on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval =
m_Client.LockServer(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Disable the Popups
Table 27: Disable the popups
Command name Parameters Description Return Value Example
SetVerboseMode() string clientID

bool _verbose
This method sets
the verbose mode
to either true or
false.
When the value
is set to true,
then any of the
message boxes
appearing during
the application
will be routed to
the client machine
which is controlling
TekExpress.
When the value is
set to false, then all
the message boxes
are shown on the
server machine.

String that gives
the status of
the operation
after it has been
performed.
When Verbose
mode is set to
true, the return
value is “Verbose
mode turned on.
All dialog box
will be shown to
client ...”.
When Verbose
mode is set to
false, the return
value is “Verbose
mode turned off.
All dialog box
will be shown to
server ...”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Verbose mode is turned on
return=m_Client.SetVerbose-
Mode(clientID, true)
Verbose mode is turned off
returnval=m_Client.SetVerbose-
Mode(clientID, false)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set or Get the DUT ID
Table 28: Set or Get the DUT ID
Command name Parameters Description Return Value Example
SetDutId() string clientID

string dutName
This method
changes the DUT
ID of the set up.
The client must
provide a valid
DUT ID.

String that gives
the status of
the operation
after it has been
performed.
Return value
is “DUT Id
Changed...” on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
return=m_Client.SetDutId(clien-
tID,desiredDutId)
Note

GetDutId() string clientID
string dutId

This method gets
the DUT ID of the
current set up.

String that gives
the status of
the operation
after it has been
performed.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
return=m_Client.GetDutid(clien-
tID, out DutId)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set the Configuration Parameters for a Suite
or Measurement

Table 29: Set the configuration parameters for a suite or measurement
Command name Parameters Description Return Value Example
SetGeneralParam-
eter()

string clientID
string device
string suite
string test
string parame-
terString

This method
sets the general
parameters that
are not specific to
any given suite or
measurement.

NOTE. Using
this command we
can select a lane,
channel, or source
type.

String that gives
the status of
the operation
after it has been
performed.
The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Lane Selection
Lane Deselection
Select Channel
Select Source Type (Differential)
Select Source Type (Single
Ended)

SetAnalyzeParam-
eter()

string clientID
string device
string suite
string test
string parame-
terString

This method sets
the configuration
parameters in the
Analyze panel of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Clientis a reference to the
Client class in the Client DLL
returnval as string
Configure Droop
Configure Power Spectral
Density
Configure Linearity
Configure Clock Frequency
Configure Jitter-Master
Configure Jitter-Slave
Configure Return Loss

SetAcquireParame-
ter()

string clientID
string device
string suite
string test
string parame-
terString

This method sets
the configuration
parameters in the
Analyze panel of
the Configuration
Panel dialog box
for a given suite or
measurement.

returnVal = re-
moteObject.Se-
tAcquireParam-
eter(id, device,
suite, test, pa-
rameterString)
if ((OP_STATUS)

returnVal !=
OP_STA-
TUS.SUC-
CESS) return
Command-
Failed(re-
turnVal)

Currently there are no
acquisitions parameters for
XGbT, hence this is not
applicable.

xxx

148 TekExpress XGbT-10GBASE-T Automated Solution



TekExpress Programmatic Interface Set the Configuration Parameters for a Suite or Measurement

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Lane Selection Example
returnval=mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane A$Included")

Lane Deselection Example
returnval=mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane A$Excluded")

Select Channel Example
returnval=mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane AConnected
to$Channel 1")

Select Source Type (Differential) Example
returnval=mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Source
Type$Differential")

Select Source Type (Single Ended) Example
returnval=mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Source Type$Single
Ended")
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Query the Configuration Parameters for a
Suite or Measurement

Table 30: Query the configuration parameters for a suite or measurement
Command name Parameters Description Return Value Example
GetGeneralParam-
eter()

string clientID
string device
string suite
string test
string parame-
terString

This method
gets the general
configuration
parameters for
a given suite or
measurement.

The return value
is the general
configuration
parameter for
a given suite or
measurement
that is set.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Lane Selection
Lane Deselection
Select Channel
Select Source Type (Differential)
Select Source Type (Single
Ended)

GetAnalyzeParam-
eter()

string clientID
string device
string suite
string test
string parame-
terString

This method gets
the configuration
parameters set
in the Analyze
panel of the
Configuration
Panel dialog box
for a given suite or
measurement.

The return
value is the
configuration
parameter set
in the Analyze
panel of the
Configuration
Panel dialog box
for a given suite
or measurement.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Configure Droop
Configure Power Spectral
Density
Configure Linearity
Configure Clock Frequency
Configure Jitter-Master
Configure Jitter-Slave
Configure Return Loss

GetAcquireParame-
ter()

string clientID
string device
string suite
string test
string parame-
terString

This method gets
the configuration
parameters set in
the Acquire panel
for a given suite or
measurement.

The return
value is the
configuration
parameter set in
the Acquire panel
for a given suite
or measurement.

Currently there are no
acquisitions parameters for
XGbT, hence this is not
applicable.

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Lane Selection Example
returnval=mClient.GetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane A$Included")

Lane Deselection Example
returnval=mClient.GetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane A$Excluded")

Select Channel Example
returnval=mClient.GetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane AConnected
to$Channel 1")

Select Source Type (Differential) Example
returnval=mClient.GetGeneralParameter(clientID, "Device", "Suite", "Droop", "Source
Type$Differential")

Select Source Type (Single Ended) Example
returnval=mClient.GetGeneralParameter(clientID, "Device", "Suite", "Droop", "Source Type$Single
Ended")

Droop Configure Parameter Examples

Table 31: Droop configure parameter examples
Parameter Example
Ref levels returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Ref Levels")
MidLevel returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "MidLevel")
Hysteresis returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Hysteresis")
Start time [ns] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Start time [ns]")
End time [ns] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "End time [ns]")
Population returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Population")
xxx
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Power Spectral Density Configure Parameter Examples

Table 32: Power Spectral Density configure parameter examples
Parameter Example
PSD Start Frequency [MHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "PSD Start Frequency [MHz]")
PSD Resolution Bandwidth [MHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "PSD Resolution Bandwidth [MHz]")
PSD Stop Frequency [MHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "PSD Stop Frequency [MHz]")
Power Level Start Frequency [MHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "Power Level Start Frequency [MHz]")
Power Level Stop Frequency [MHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "Power Level Stop Frequency [MHz]")
xxx

Linearity Configure Parameter Examples

Table 33: Linearity configure parameter examples
Parameter Example
Start Frequency [KHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Linearity", "Start Frequency [KHz]")
Stop Frequency [KHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Linearity", "Stop Frequency [KHz]")
Resolution Bandwidth [KHz] returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Linearity", "Resolution Bandwidth [KHz]")
xxx

Clock Frequency Configure Parameter Examples

Table 34: Clock Frequency configure parameter examples
Parameter Example
Ref Levels returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Clock Frequency", "Ref Levels")
MidLevel returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Clock Frequency", "MidLevel")
Hysteresis returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Clock Frequency", "Hysteresis")
xxx

152 TekExpress XGbT-10GBASE-T Automated Solution



TekExpress Programmatic Interface Query the Configuration Parameters for a Suite or Measurement

Jitter-Master Configure Parameter Examples

Table 35: Jitter-Master configure parameter examples
Parameter Example
Ref Levels returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "Ref Levels")
MidLevel returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "MidLevel")
Hysteresis returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "Hysteresis")
Apply Filter returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "Apply Filter")
xxx

Jitter-Slave Configure Parameter Examples

Table 36: Jitter-Slave configure parameter examples
Parameter Example
Ref Levels returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "Ref Levels")
MidLevel returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "MidLevel")
Hysteresis returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "Hysteresis")
Apply Filter returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "Apply Filter")
xxx

Return Loss Configure Parameter Examples

Table 37: Return Loss configure parameter examples
Parameter Example
Acquisition Averages returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Return Loss", "Acquisition Averages")
Smooth Averaging returnval = mClient.GetAnalyzeParameter(clientID, "Device", "Suite",

"Return Loss", "Smooth Averaging")
xxx
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Select a Measurement
Table 38: Select a measurement
Command name Parameters Description Return Value Example
SelectTest() string clientID

string device
string suite
string test
bool isSelected

This method
selects or
deselects a given
test.
Setting parameter
isSelected to true,
you can select a
measurement.
Setting parameter
isSelected to false,
you can deselect a
measurement.

String that
displays the
status of the
operation after
it has been
performed.
The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Select Measurement (Droop):
returnval=m_Client.Se-
lectTest(clientID, "Device",
"Suite", "Droop", true)
Select Measurement (Power
Spectral Density):
returnval=mClient.Se-
lectTest(clientID, "Device",
"Suite", " Linearity->Tone-2",
True)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select a Suite
Table 39: Select a suite
Command name Parameters Description Return Value Example
SelectSuite() string clientID

string device
string suite
bool isSelected

This method
selects or
deselects a given
suite.
Setting parameter
isSelected to true,
you can select a
suite.
Setting parameter
isSelected to false,
you can deselect a
suite.

String that gives
the status of
the operation
after it has been
performed.
The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client DLL
returnval as string
Select Suite (Default):
returnval=m_Client.Select-
Suite(clientID, "Device", "Suite",
true)
Select Calibration Suite:
returnval=mClient.SelectTest(cli-
entID, "Device", "Calibration",
true)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Configure the Selected Measurement

Droop Configure Parameter Examples

Table 40: Droop configure parameter examples
Parameter Example
Ref levels returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Ref Levels$Absolute")
MidLevel returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "MidLevel$50")
Hysteresis returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Hysteresis$5")
Start time [ns] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Start time [ns]$10")
End time [ns] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "End time [ns]$90")
Population returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Droop", "Population$1000")
xxx

Power Spectral Density Configure Parameter Examples

Table 41: Power Spectral Density configure parameter examples
Parameter Example
PSD Start Frequency [MHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "PSD Start Frequency [MHz]$1")
PSD Resolution Bandwidth [MHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "PSD Resolution Bandwidth [MHz]$1")
PSD Stop Frequency [MHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "PSD Stop Frequency [MHz]$3000")
Power Level Start Frequency [MHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "Power Level Start Frequency [MHz]$1")
Power Level Stop Frequency [MHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Power Spectral Density", "Power Level Stop Frequency [MHz]$3000")
xxx
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Linearity Configure Parameter Examples

Table 42: Linearity configure parameter examples
Parameter Example
Start Frequency [KHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Linearity", "Start Frequency [KHz]$1000")
Stop Frequency [KHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Linearity", "Stop Frequency [KHz]$400000")
Resolution Bandwidth [KHz] returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Linearity", "Resolution Bandwidth [KHz]$20")
xxx

Clock Frequency Configure Parameter Examples

Table 43: Clock Frequency configure parameter examples
Parameter Example
Ref Levels returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Clock Frequency", "Ref Levels$Absolute")
MidLevel returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Clock Frequency", "MidLevel$50")
Hysteresis returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Clock Frequency", "Hysteresis$5")
xxx

Jitter-Master Configure Parameter Examples

Table 44: Jitter-Master configure parameter examples
Parameter Example
Ref Levels returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "Ref Levels$Absolute")
MidLevel returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "MidLevel$50")
Hysteresis returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "Hysteresis$5")
Apply Filter returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Master", "Apply Filter$True")
xxx

TekExpress XGbT-10GBASE-T Automated Solution 157



TekExpress Programmatic Interface Configure the Selected Measurement

Jitter-Slave Configure Parameter Examples

Table 45: Jitter-Slave configure parameter examples
Parameter Example
Ref Levels returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "Ref Levels$Absolute")
MidLevel returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "MidLevel$50")
Hysteresis returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "Hysteresis$5")
Apply Filter returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Jitter-Slave", "Apply Filter$True")
xxx

Return Loss Configure Parameter Examples

Table 46: Return Loss configure parameter examples
Parameter Example
Acquisition Averages returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Return Loss", "Acquisition Averages$10")
Smooth Averaging returnval = mClient.SetAnalyzeParameter(clientID, "Device", "Suite",

"Return Loss", "Smooth Averaging$5")
xxx
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Run with Set Configurations or Stop the Run
Operation

Table 47: Run with set configurations or Stop the run operation
Command name Parameters Description Return Value Example
Run() string clientID Runs the selected

measurements.
Note
Once the server
is set up and is
configured, it can
be run remotely
using this function.

String that gives
the status of
the operation
after it has been
performed.
The return value
is "Run started..."
on success.

m_Client = new Client()
//m_Clientis a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Run(clien-
tID)

Stop() string clientID Stops the
currently running
measurements.
Note

String that gives
the status of
the operation
after it has been
performed.
The return value
is "Stopped..." on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Stop(clien-
tID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Get or Set the Timeout Value
Table 48: Get or Set the Timeout value
Command name Parameters Description Return Value Example
GetTimeOut() string clientID Returns the current

timeout period set
by the client.

String that gives
the status of
the operation
after it has been
performed.
The default
return value is
1800000.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.GetTime-
Out()

SetTimeOut() string clientID
string time

Sets a timeout
period specified by
client. After expiry
of this timeout
period, the server
is automatically
unlocked.

String that gives
the status of
the operation
after it has been
performed.
On success the
return value is
“TimeOut Period
Changed”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.SetTime-
Out(clientID, desiredTimeOut)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Wait for the Test to Complete
The commands in this group are executed while tests are running. The GetCurrentStateInfo() and
SendResponse() commands are executed when application is running and in wait state.
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Table 49: Wait for the test to complete
Command name Parameters Description Return Value Example
ApplicationStatus() string clientID This method gets the

status of the server
application.
The states at a given
time are Ready,
Running, Paused,
Wait, or Error.

String value that
gives the status
of the server
application.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Applica-
tionStatus(clientID)

QueryStatus() string clientID
out string[]
status

It is an interface for
the user to transfer
Analyze panel status
messages from the
server to the client.

String that gives
the status of
the operation
after it has been
performed.
On success the
return value is
“Transferred...”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnVal=m_Client.QueryS-
tatus(clientID, out statusMes-
sages)
if ((OP_STATUS)returnVal ==
OP_STATUS.SUCCESS)

return “Status updated...”
else

return CommandFailed(re-
turnVal)
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Table 49: Wait for the test to complete (cont.)

Command name Parameters Description Return Value Example
GetCurrentState-
Info()

NOTE. This
command is
used when the
application is
running and is in
the wait or error
state.

string clientID
out string
caption
out string
message
out string[]
buttonTexts

This method gets
the additional
information of the
states when the
application is in Wait
or Error state.
Except client ID, all
the others are out
parameters.

This command
does not return
any value.
This function
fills up the out
parameters that
are passed
when invoking
this function.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
m_Client.GetCurrentState-
Info(clientID, caption,message,
buttonTexts)

SendResponse()

NOTE. This
command is
used when the
application is
running and is in
the wait or error
state.

string clientID
out string
caption
out string
message
string response

After receiving the
additional informa-
tion using the method
GetCurrentState-
Info(), the client can
decide on the re-
sponse to send and
send the response
to the application us-
ing this function.The
response should be
one of the strings that
was earlier received
as a string array in
the GetCurrentState-
Info function.The
_caption and _mes-
sage should match
the information re-
ceived earlier in the
GetCurrentStateInfo
function.

This command
does not return
any value.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
m_Client.SendResponse(cli-
entID, caption,message,
response)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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After the Test is Complete
Table 50: After the test is complete
Command name Parameters Description Return Value Example
GetPassFailSta-
tus()

string clientID
string device
string suite
string test

This method gets
the pass or fail
status of the
measurement after
test completion.

NOTE. Execute
this command
after completing
the measurement.

String that gives
the status of
the operation
after it has been
performed.
Returns the pass
or fail status in
the form of a
string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.GetPass-
FailStatus(clientID, device,
suite, ”Droop”) //Pass or Fail

GetResultsValue() string clientID
string device
string suite
string test
string parame-
terString

This method gets
the result values of
the measurement
after the run.

String that gives
the status of
the operation
after it has been
performed.
Returns the
result value in
the form of a
string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as srting
returnval=m_Client.GetRe-
sultsValue(clientID, "Device",
"Suite", "Droop", "Lane ARe-
sults")
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Table 50: After the test is complete (cont.)

Command name Parameters Description Return Value Example
GetResultsValue-
ForSubMeasure-
ments()

string clientID
string device
string suite
string test
string parame-
terString
int rowNr

This method gets
the result values
for individual sub-
measurements,
after the run.

String that gives
the status of
the operation
after it has been
performed.
Returns the
result value in
the form of a
string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Droop Positive
returnval=m_Client.GetRe-
sultsValueForSubMeasure-
ments(clientID, "Device",
"Suite", "Droop", "Lane ARe-
sults",0)
Linearity Tone 4
returnval=m_Client.GetRe-
sultsValueForSubMeasure-
ments(clientID, "Device",
"Suite", "Linearity", "Lane BRe-
sults",3)

GetReportParame-
ter()

string clientID
string device
string suite
string test
string parame-
terString

This method
gets the general
report details such
as oscilloscope
model, TekExpress
version, and XGbT
version.

The return
value is the
oscilloscope
model,
TekExpress
version, and
XGbT version.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
Oscilloscope Model
returnval=m_Client.GetRe-
portParameter(clientID,"Scope
Model")
TekExpress Version
returnval=m_Client.GetReport-
Parameter(clientID,"TekExpress
Version")
XGbT Version
returnval=m_Client.GetRe-
portParameter(clientID,"XGbT
Version")
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Table 50: After the test is complete (cont.)

Command name Parameters Description Return Value Example
TransferReport() string clientID

string filePath
This method
transfers the report
generated after the
run.
The report
contains the
summary of the
run.
The client must
provide the
location where
the report is to
be saved at the
client-end.

String that gives
the status of
the operation
after it has been
performed.
Transfers all the
result values in
the form of a
string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.TransferRe-
port(clientID,"C:\Report”)

TransferWave-
forms()

string clientID
string filePath

This method
transfers all the
waveforms from
the folder for the
current run.

NOTE. For each
click of Run
button, a folder
is created in the X:
drive. Transfer the
waveforms before
clicking the Run
button.

String that gives
the status of
the operation
after it has been
performed.
Transfers all the
waveforms in the
form of a string.
On success the
return value is
“Transferred...”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Transfer-
Waveforms(clientID,"C:\Wave-
forms”)

TransferImages() string clientID
od
string filePath

This method
transfers all
the images
(screenshots) from
the folder for the
current run (for
a given suite or
measurement).

NOTE. For each
click of Run
button, a folder
is created in the X:
drive. Transfer the
waveforms before
clicking the Run
button.

String that gives
the status of
the operation
after it has been
performed.
Transfers all the
images in the
form of a string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.TransferIm-
ages(clientID, "C:\Waveforms”)

xxx
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NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

string parameterString

Name Type Direction Description
parameterString string IN Specifies the oscilloscope model,

TekExpress version, and XGbT
version.

xxx
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Save, Recall, or Check if a Session is Saved
Table 51: Save, Recall, or Check if a session is saved
Command name Parameters Description Return Value Example
CheckSession-
Saved()

string clientID
out bool saved

This method is
called when a
check is to be
made to know if
the current session
is saved.

Return value is
either True or
False.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Check-
SessionSaved(m_clientID, out
savedStatus)

RecallSession() string clientID
string name

Recalls a saved
session. The
name of the
session is provided
by the client.

String that gives
the status of
the operation
after it has been
performed.
The return value
is “Session
Recalled...”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.RecallSes-
sion(clientID, savedSession-
Name)

SaveSession() string clientID
string name

Saves the current
session. The
name of the
session is provided
by the client.

String that gives
the status of
the operation
after it has been
performed.
The return value
is "Session
Saved..."/"Failed...".

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.SaveSes-
sion(clientID, desiredSession-
Name)

SaveSessionAs() string clientID
string name

Saves the current
session in a
different name
every time this
method is called.
The name of the
session is provided
by the client.

String that gives
the status of
the operation
after it has been
performed.
The return value
is "Session
Saved...".

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.SaveSes-
sionAs(clientID, desiredSes-
sionName)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Unlock the Server
Table 52: Unlock the server
Command name Parameters Description Return Value Example
UnlockSession() string clientID This method

unlocks the server
from the client.
The ID of the client
to be unlocked
must be provided.
Note

String that gives
the status of
the operation
after it has been
performed.
The return value
is "Session
Un-Locked...".

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Unlock-
Server(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Disconnect from the Server
Table 53: Disconnect from the server
Command name Parameters Description Return Value Example
Disconnect() string clientID This method

disconnects
the client from
the server it is
connected to.
Note

Integer value that
gives the status
of the operation
after it has been
performed.
1 for Success
–1 for Failure

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL
returnval as string
returnval=m_Client.Discon-
nect(m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Handle Error Codes
The return value of the remote automations at the server-end is OP_STATUS which is changed to a string
value depending on its code and returned to the client. The values of OP_STATUS are as follows:

Value Code Description
FAIL −1 The operation failed.
SUCCESS 1 The operation succeeded.
NOTFOUND 2 Server not found
LOCKED 3 The server is locked by another client, so operation cannot

be performed.
UNLOCK 4 The server is not locked. Lock the server before performing

the operation.
NULL 0 Nothing
xxx

Program Example
This is a reference program to illustrate how to communicate to TekExpress XGbT-10GBASE-T remotely.

A typical application does the following:

1. Start the application.

2. Connect through an IP address.

m_Client.Connect("localhost") ’True or False

clientID = m_Client.getClientID

3. Lock the server.

m_Client.LockServer(clientID)

4. Disable the Popups.

m_Client.SetVerboseMode(clientID, false)

5. Set the Dut ID.

m_Client.SetDutId(clientID, "DUT_Name")

6. Select a source type.

mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Source

Type$Differntial") ’Droop measurement selected

7. Select a lane.

mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop",

"LaneA$Included") ’Droop measurement selected
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8. Select a measurement.

mClient.SelectTest(clientID, "Device", "Suite", "Droop", true) ’Droop
measurement selected

9. Select a channel.

mClient.SetGeneralParameter(clientID, "Device", "Suite", "Droop", "Lane

AConnected to$Channel 1") ’Droop measurement selected

10. Configure the selected measurement.

mClient.SetAnalyzeParameter(clientID, "Device", "Suite", "Droop", "Ref

Levels$Percentage") ’Droop measurement selected

mClient.SetAnalyzeParameter(clientID, "Device", "Suite", "Droop",

"MidLevel$40") ’Droop measurement selected

mClient.SetAnalyzeParameter(clientID, "Device", "Suite", "Droop",

"Hysteresis$5") ’Droop measurement selected

mClient.SetAnalyzeParameter(clientID, "Device", "Suite", "Droop", "Start

Time [ns]$8") ’Droop measurement selected

mClient.SetAnalyzeParameter(clientID, "Device", "Suite", "Droop", "End Time

[ns]$92") ’Droop measurement selected

mClient.SetAnalyzeParameter(clientID, "Device", "Suite", "Droop",

"Population$2000") ’Droop measurement selected

11. Run with set configurations.

m_Client.Run(clientID)

12. Wait for the test to complete.

Do

Thread.Sleep(500)

m_Client.Application_Status(clientID)

Select Case status

Case "Wait"

’Get the Current State Information

mClient.GetCurrentStateInfo(clientID, WaitingMsbBxCaption, WaitingMsbBxMes-

sage, WaitingMsbBxButtontexts)

’Send the Response

mClient.SendResponse(clientID, WaitingMsbBxCaption, WaitingMsbBxMessage,

WaitingMsbBxResponse)

End Select

Loop Until status = "Ready"
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13. After the Test is Complete.

’Save all results values from folder for current run

m_Client.TransferResult(clientID, logDirname)

’Save all waveforms from folder for current run

m_Client.TransferWaveforms(clientID, logDirname)

’Save all images from folder for current run

m_Client.TransferImages(clientID, logDirname)

14. Unlock the server.

m_Client.UnlockServer(clientID)

15. Disconnect from server.

m_Client.Disconnect()

16. Exit the application.

NI TestStand Client Example
The following is an example for NI TestStand Client available in the path, C:\Program
Files\Tektronix\TekExpress\TekExpress XGbT-10GBASE-T\Examples\Programmatic

Interface\TestStand
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Measurement Standards
Table 54: Measurement standards

Test name Purpose
Reference to the
standard What the standard says

Droop To verify that the
transmitter output
level does not decay
faster than the
maximum specified
rate.

IEEE standard
802.3an-2006,
subclause 55.5.2, Test
modes.
IEEE standard
802.3an-2006,
subclause 55.5.3.1,
Maximum output droop.

IEEE standard 802.3an-2006, subclause
55.5.2: Configure the DUT for test mode 6
operation.
IEEE standard 802.3an-2006, subclause
55.5.3.1: Maximum output droop provides a
specification for the maximum allowable droop
for the transmitter.
The resulting magnitude of both the positive
and negative droop shall be less than 10%.

Power Spectral
Density

To verify that the
transmitter power
level and power
spectral density
are within the
conformance limits.

IEEE standard
802.3an-2006,
subclause 55.5.2, Test
modes.
IEEE standard 802.3an,
subclause 55.5.3.4,
Transmitter PSD and
power level.

IEEE standard 802.3an, subclause 55.5.2:
Configure the DUT for test mode 5 operation.
The transmit power shall be between 3.2 dBm
and 5.2 dBm.
The power spectral density, measured into 100
Ω, shall fit within the upper and lower masks.

Linearity To verify that
the output of
the transmitter
conforms to the
transmitter linearity
mask.

IEEE standard
802.3an-2006,
subclause 55.5.2, Test
Modes.
IEEE standard 802.3an,
subclause 55.5.3.2,
Transmitter linearity.

IEEE standard 802.3an-2006, subclause
55.5.2: Configure the DUT for test mode 4
operation.
The SFDR of the transmitter when subjected
to single tone inputs produce an output
peak-to-peak transmit amplitude meets the
requirement:
SFDR ≥ 2.5 + min{52,58 − 20 * log (f/25)}
Where
f is the maximum frequency of the two test
tones in MHz
SFDR (in dB) is the ratio of the minimum RMS
value of either input tone to the RMS value
of the worst intermodulation product in the
frequency range of 1 to 400 MHz.
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Table 54: Measurement standards (cont.)

Test name Purpose
Reference to the
standard What the standard says

Clock Frequency To verify that
the frequency
of the Transmit
Clock is within the
conformance limits.

IEEE standard
802.3an-2006,
subclause 55.5.2, Test
modes.
IEEE Std 802.3an-2006,
clause 55.5.3.5,
Transmit clock
frequency.

IEEE standard 802.3an-2006, subclause
55.5.2: Configure the DUT for test mode 2
operation.
The IEEE Std 802.3an-2006, clause 55.5.3.5:
The 10GBase-T devices when operating in
Master timing mode must have a quinary
symbol transmission rate of 800.00 MHz ±
50 ppm.
The IEEE Std 802.3an-2006, clause 55.5.3.5:
The frequency of the reference clock that is
extracted from the transmitted waveform has a
base frequency of 800 MHz ± 50 ppm.

Jitter-Master To verify that
the transmitter
timing jitter of the
PMA is within the
conformance limits.

IEEE standard
802.3an-2006,
subclause 55.5.2, Test
modes.
IEEE standard
802.3an-2006,
subclause 55.12.6,
Item PME21 (Master).

The IEEE standard 802.3an-2006, subclause
55.5.2: Configure the DUT for transmitter test
mode 2 operation.
The IEEE standard 802.3an-2006, subclause
55.5.3.3: Transmit timing jitter the RMS period
jitter (for a integration time interval of 1 ms ±
10%) is the root mean square period difference
from the average period (T – Tavg) that is
accumulated over a sample size of
200,000 ± 20,000.

Jitter-Slave To verify that
the transmitter
timing jitter of the
PMA is within the
conformance limits.

IEEE standard
802.3an-2006,
subclause 55.5.2, Test
modes.
IEEE standard
802.3an-2006,
subclause 55.12.6,
Item PME22 (Slave).

For a PHY supporting loop timing mode, the
SLAVE PHY is in test mode 3.
The SLAVE must synchronize its transmit clock
to the signals received from the MASTER PHY.
The RMS period jitter measured at the SLAVE
PHY MDI output shall be less than 5.5 ps.

Return Loss To measure the
return loss at the
MDI for all four
channels

IEEE Std 802.3an-2006,
subclause 55.5.3 – Test
modes.
IEEE Std 802.3an-2006,
subclause 55.8.2.1 –
MDI return loss.

Set the DUT to test mode 4 Tone 1.
Specifies that the Return Loss (reflected
power) at the MDI must be at least 16 dB less
than the incident power over the range of 1.0
MHz to 40 MHz.
The return loss must be at least 16 dB
(10*log10(f /40)) from 40 MHz to 400 MHz and
at least 6 dB (30*log10(f /400)) from 400 MHz
to 500 MHz (where f is in MHz).
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Table 54: Measurement standards (cont.)
xxx

Shortcut Keys
The following table lists the short cut keys to access the application:

Table 55: Shortcut keys
Menu Shortcut keys
File Alt + F
New Session Ctrl + N
Open Session Ctrl + O
Save Session Ctrl + S
Save Session As Alt + F + A
Save Report As Alt + F + R

Ctrl + R
Print Preview Report Alt + F + V

Ctrl+ V
Print Report Ctrl + P
Exit Ctrl + X
View Alt + V
Log Ctrl + L
Tools Alt + T
Instrument Bench Ctrl + I
Help Alt + H
TekExpress Help (F1) Alt + H + H
About TekExpress Alt + H + A
xxx

Error Codes for XGbT
The following table lists the error codes and their descriptions:

Table 56: Error Codes for XGbT
Error code Error message Description Possible solution
50101 Insufficient number of

edges
The combination of Mid
Level and Hysteresis
values are such that the
measurement does not find
any edges.

Set the Mid level close to
50% (in Percentage option)
or 0 (in Absolute) and
Hysteresis close to 3% (in
Percentage option) or 0.03
(in Absolute option).
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Table 56: Error Codes for XGbT (cont.)

Error code Error message Description Possible solution
50102 Start time is after the stop

time
The stop time of the
measurement is before
the start time of the
measurement. The user
should check the start and
stop time values.

Make sure that the start
time value is smaller than
the stop time.

50103 Data points are less than
the number of peaks
required

The user should check
the start frequency, stop
frequency and resolution
bandwidth setting. If
the waveform does not
have enough frequencies
between the start and stop
frequency, this error will
occur.

Set the Start Frequency,
Stop Frequency, and
Resolution Bandwidth such
that (Start Frequency -
Stop Frequency)/Resolution
Bandwidth >= 3.

50104 Start frequency is greater
than stop frequency

The stop frequency of
the measurement should
be higher than the start
frequency. The user should
check the start and stop
frequency values.

Make sure that the start
frequency is smaller than
the stop frequency.

50105 Data points insufficient for
average filtering

The number of data points
in the waveform are too
few for average filtering.
This problem can occur
when there are not many
frequency values between
the start and stop frequency.

Increase the Sample Rate.

50106 Invalid Linearity Signal Incorrect signal is used for
the Linearity test.

Connect to the appropriate
Linearity signal.

50107 Invalid Path The intermediate files
required by the algorithm
library are not stored in the
correct path.

Return Loss measurement
is not able to find calibration
data. Check if the X: is
available for read and write.

50108 Negative spacing between
output data points

The interpolated points
have negative spacing
between them. This error
will not occur under normal
run conditions.

Make sure smooth
averaging is ≥ 0.

50109 Data length should be
positive

The smooth averaging is <
0.

Make sure smooth
averaging is ≥ 0.

50110 Averaging filter length
should be a positive integer

The smooth averaging is <
0.

Make sure smooth
averaging is ≥ 0.
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Table 56: Error Codes for XGbT (cont.)

Error code Error message Description Possible solution
50111 Waveform file not found +

WAVEFORM NAME
This error occurs when the
input waveform required
for the measurement is not
available.

Ensure that the input
waveform required for the
measurement is present in
the correct session folder.

59999 Unknown error Incorrect signal is used for
the test.

Check the input signal and
provide correct input signal.

xxx
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